Toyota RAV4 Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
Following up from a rear camera job, my dash is not showing up the current gear selection anymore.
I have removed the camera wiring to isolate this, and its still now showing up.
I have traced the wiring from the boot back and i cant see anything that is not plugged in.
Is there a plug or somthing on the gearbox or in the inside that controls what the dash see's as a gear selector?
its all just blank, i can see the letters but no surrounds on what gear i am currently in.
thanks guys.,
This may shed some light on why my reverse lights are not working, which will lead me onto my next issue of fixing my reverse camera.
thanks
 

·
Super Moderator
Joined
·
9,040 Posts
Most likely you caused a short during installation and blew a fuse.
BTW you should post followups on the original thread so we see the whole story.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #3
hmmm, yea i pulled the glovebox out this morning to see what fuses are behind that, not much... its just a few relays.
In the engine bay there are 2x fuse boxes but i checked all the fuses and they all are fine.

Would it be a relay ?
 

·
Registered
Joined
·
43 Posts
Discussion Starter #4
here was the info from the other thread.
--
I wired in a numberplate camera, it had its 12V and a ground and the signal needed a 12V, so i joined the 2x 12V and then tapped into the reverse light 12V. i grounded the ground with an eyelet on an existing ground on the tail gate.
anyways, hours later, and swearing and etc. i get the signal cable up to the front, and nothing.... its not working...
I then find i have no reverse lights at all anymore, nor the reverse sensors.
mine also has a tow pack so thats tapped from the left side ... anyway, ive been trying to isolate and get my lights back and my dash gear indicator PNRD etc. and im all out of ideas.... ive unplugged everything thats tapped off the rear reverse lights (parking sensors, tow pack) and it should be stock and i still have no rear lights...

ive checked fuses .... anyone have any ideas?
why would the dash gear stuff no longer be showing up just because of the rear lights ?
--
 

·
Registered
Joined
·
43 Posts
Discussion Starter #5
Ok another weird one...
I just went out and the battery is dead, i jump it, and its not charging...
I ran a quick scantool on it, and P0705 PRNDNL circut.
... Im getting pretty lost here why would that effect the alternator
 

·
Registered
Joined
·
43 Posts
Discussion Starter #6
ok, i had enough... i called an auto elec and limped it there on a non-charging battery.
lucky i had my boost pack i plugged in after about 2kms.
Hopefully he can get to the bottom of it.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #7
Car is all fixed now.
I had missed the fuses behind the glove box, UNDERNETH looking up....
$230 later, the auto elec found that problem, charged up the battery, said that he wasn't sure why the alternator wasn't charging, because the exciter wire was fine, the gear selector is now working which gave me my rear reverse lights again, he removed a bunch of unnecessary add-on wiring that the previous owner had all bundled up and also cleaned up the tow pack wiring and then we got the camera wired up,
The camera wire thats on the RCA (little red wires at each end) wasn't passing 12v, so we just ran an indipendent 12v wire from the back up to the front.
The interior was really stripped back as i was going nuts trying to sort it out, this made his job much easier.
Im a little annoyed i got beaten by essentially 1 blown fuse, but given i'd spent a day on this and i had to take a day off work and its my main car, i needed it done ASAP.
oh and i also found a nice little surprise when i decided to check the cabin air filter.
have a look at the pics.
Now ive only owned this car for about 3 weeks, lets just say, im ordering a new filter tonight.
 

Attachments

·
Super Moderator
Joined
·
9,040 Posts
Glad you got it fixed and it's always good to remove old non-functioning wiring since you never know what future mysteries it can cause.

I deleted your other thread since you quoted it here.
 

·
Registered
Joined
·
2,478 Posts
Geniee it is confusing when you say behind the glove box you missed the fuse. That fuse you blew is under the left kick panel. There are no fuses behind the glove box.


It would be a good idea if you read your owners manual to know your car better. Downloading the repair manual would also be beneficial if you are planning on working on your car.
 

·
Your Humble Administrator
Joined
·
16,418 Posts
Geniee it is confusing when you say behind the glove box you missed the fuse. That fuse you blew is under the left kick panel. There are no fuses behind the glove box.


It would be a good idea if you read your owners manual to know your car better. Downloading the repair manual would also be beneficial if you are planning on working on your car.
He is from Australia, so his fuse box is on the left just like ours, but behind the glove box because the steering wheel is on the right. If he had mentioned this from the start, it would have cleared up a lot of confusion.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #11
Oh yea, sorry guys, good point, yea its a Right hand drive Australian delivered car.
Yea, ive had Haynes and Gregories manuals in the past for other cars, still trying to workout which is more detailed, i believe the haynes one was a little low on detail when comparing the two, but i will look into that.
thanks again.
--
I updated my profile and will be clearer next time about the specifics.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #13
not sure, as stated above, im in australia, so we have the driver side on the right, in my case there was a fuse box on the left (passenger) side under the outer side, i had to get on the floor and look up to see another fuse box.
Best to get a multimeter and pull fuses and check.
Sorry i cant be of more help.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #15
awesome, i have no idea what theyh did to the LHD versions. I did use a OBD2 thing, and it was throwing up codes for trhe PRDNL circut.
On another note..... The stars at night are big and bright. Deep in the heart of Texas
 

·
Registered
Joined
·
43 Posts
Discussion Starter #18
it was a year ago, i know it was the cabin fuse box, and if i had have known it was there, would have been very easy to test each fuse with a multimeter.
I cant recall, but, i was wiring in a backup camera and shorted the reverse lights, if that helps.
If you have a multi meter, lay under there and test them.
 
1 - 18 of 18 Posts
About this Discussion
17 Replies
5 Participants
Geniee
Toyota RAV4 Forums
Rav 4 World is the internet's largest Toyota Rav4 SUV and EV online forum community. Discuss towing, modifications, and more.
Full Forum Listing
Top