Toyota RAV4 Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
SO we came back from the city this morning...and my wife decided to clean her car (2008 RAV4) out.
Once finished, she tried to start the vehicle but it is dead....no dash lights come on...engine doesn't turn over...nothing.

I though maybe the battery in the fob, but that didn't change our predicament....jump starting did nothing...now what?
 

·
Registered
Joined
·
45 Posts
You are leaving out the information that helps us to help you. When jumping, does it turn over but not start? Does the headlights come on. Any dash lights at all etc.....
 

·
Registered
Joined
·
23 Posts
Discussion Starter #4
Looks like I posted in panic-mode...subsequent jumps starts DID work. I used one of those "micro start" battery packs, but it went dead after the first attempt, so it probably wasn't fully charged.

It looks like the main vehicle battery is toast. It's been on the charger for the past hour and the needle hasn't moved.
I'll leave it overnight, but it looks like a trip to Costco is in our future.
 

·
Registered
Joined
·
220 Posts
Leaving the doors open for a few hrs on a weak battery while cleaning might have killed the battery. If that's your original battery, you did well. Costco is a great place for a replacement battery.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #6
I'm thinking that might have had something to do with it....
So, when starting the vehicle....do the DRL's stay OFF if you disengage the parking brake? I know they did in our old XL-7, but I haven't had to experiment with the RAV until now.
While DRLs are a good feature, they can be a real PITA at times....like this.
 

·
Registered
Joined
·
220 Posts
My 08 does. They only come on when I release the E brake after start up. If the E brake wasn't pulled before start up, then they come on when the engine starts normally.
Was that the original battery?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #9
My 08 does. They only come on when I release the E brake after start up. If the E brake wasn't pulled before start up, then they come on when the engine starts normally.
Was that the original battery?
No...it was a Costco replacement, but I cannot read the date.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #10
Solved...it was the battery after all, sorry for panic!
The original battery was a Costco-special, dated 08/2014 so it was well-past its due date. But it still surprises me how it was functional one minute, then dead-as-a-doornail the next.
 

·
Registered
Joined
·
322 Posts
Twelve volt batteries do that. I had one that started the car just fine, drove a mile and parked. Went into a store for 15 minutes, and when I came out, the battery wouldn't even light the dome light. Radio was dead. Replace battery and all was good. That was a few years ago, and not a Toyota.
 
1 - 11 of 11 Posts
Top