Toyota RAV4 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello all. I'm a new owner of a 2013 Rav XLE and traded in my 2006 RAV4 base with just over 208,000 miles on it. (Purchased with on 9000 miles on it almost 10 years ago).

I miss my buggy, loved her to pieces, but it was time for more safety features and she was making noises unbecoming of a lady.

So this new buggy is taking some getting used to... She's quiet, she manuvers beautifully, it's got all the bells and whistlesi wanted including moonroof.

Here's my problem:
The display is wrong/ confusing. At highway speeds (usually around 75 or 80 mph) the digital display says I'm going 40mph. The speedometer is correct... But the digital display is not.

Anyone know how to reset? If this were a computer I'd do a shutdown and restart but this doesn't quite work that way.

Thanks for any help!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thanks for the reply Saturday. :smile

It does say average.. But it also matches the digital display in the instrument cluster that doesn't say average. So are both the displays showing average? How do I get them to show actual?

Thanks again.
 

·
Premium Member
Joined
·
2,505 Posts
You should be able to reset any trip meter and the gas mileage by simply pressing the button and hold it for a few seconds.
Did you get an owners manual with the vehicle?
.
 

·
Registered
Joined
·
548 Posts
The display on mine is similar. I do stop and go driving, sometimes reaching speeds of 40 MPH, but my average speed display is stuck at 12 MPH.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
You should be able to reset any trip meter and the gas mileage by simply pressing the button and hold it for a few seconds.
Did you get an owners manual with the vehicle?
.
I did not... But I downloaded manuals from the Toyota site. Can't find anything on the display though (yet).
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
The display on mine is similar. I do stop and go driving, sometimes reaching speeds of 40 MPH, but my average speed display is stuck at 12 MPH.
Yes! That's what is on mine... Why would anyone want average mph? I want ACTUAL. Mph!
 

·
Registered
Joined
·
1,365 Posts
Yes! That's what is on mine... Why would anyone want average mph? I want ACTUAL. Mph!
Well, because that's what the speedometer is for.

And if you press the display button on the steering wheel it cycles through other information. None of which is your current speed ......because the speedometer already tells you that. I mean, by definition, it is the speed-o-meter.

Congrats on your rav4.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Well, because that's what the speedometer is for.

And if you press the display button on the steering wheel it cycles through other information. None of which is your current speed ......because the speedometer already tells you that. I mean, by definition, it is the speed-o-meter.

Congrats on your rav4.
Yes... The speedometer. I have issues with that too... Why is it set for every 20 miles with markers for every ten? What happened to the "5" markers?
Or am I just getting to old and crotchety about little things? :wink
If I want to drive 65 I have to guess. When did this change?
 

·
Premium Member
Joined
·
1,427 Posts
The speedometer is wrong anyways.
If you want to go 65, just put the speedo a tick below 70 and call it good... you'll be in the 64-55 range.
 
1 - 10 of 10 Posts
Top