Toyota RAV4 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Sent off my Ecu to check engine, rav (2001 gas) was having trouble at highway speeds, especially past 90km/h and uphill, also hesitant in 1st gear. Got it back and now it seems it doesn't want to shift past 2nd gear, can hardly drive past 30km/h. Does anybody have any idea what's happening? I'm beginning to lose hope. Any help appreciated!
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,712 Posts
Talk to Sergei at Check Engine and tell him the problem is worse with the repaired ECM. He will probably ask you to send it back to him, or maybe he will swap it with another ECM.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Yes just talked to him today, he is going to send me a new one.

What I don't understand is if it's the transmission, why I am dealing with a different version of the same problem. And if I go and get a new transmission if these problems will still persist. Does anybody have any suggestions?
 

·
Registered
Joined
·
47 Posts
it's probably the ECU. I had something similar where I got a refurb (already fixed) ECU off ebay and swapped and that worked for a few days, then things got really weird (stuck in one gear). They sent another one, and it's been fine since.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Just to give everybody an update, took the rav to a full service shop, and eventually found out the problem was a dirty/faulty MAF sensor, which was throwing off the air/fuel ratio. Had it replaced and it runs like new! Hopefully sending away the ECU will no mean I don't have to worry about it giving me problems in the future, or maybe it was just a waste of money. But Rav is back on the road anyways.
 
1 - 5 of 5 Posts
Top