Toyota RAV4 Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi folks,

I have a 2002 Rav4 that I really screwed up. I recently replaced the battery and made the mistake of putting it in backwards and trying to start it. I blew the ignition fuse and caused several other electrical problems. After replacing the ignition fuse, it starts and idles well. But, it won't shift into gear, and the locks, windows, wipers, clock, and mirrors don't work. Some dash lights work, but the gauges don't. The a/c, heater, and fan don't work. The sun roof doesn't work. The blinkers don't work, but do if I turn on the emergency flashers.

About the only thing that does work are the dome lights, open door chime, and lowbeam headlights. The high beams work if I pull toward me to flash them, but not if I push them out to leave them on. I've tested with my multimeter every fuse in the box under the hood and in the box under the dash and even replaced a lot of fuses with brand new fuses even though the old ones were functional. Today I went so far as to replace the brakelight switch under the dash to see if that fixed the locked shifter, but to no avail.

I'm starting to fear that I'm going to have to replace harnessing, but I'm wondering if there's anything else I'm missing. Maybe a relay or other fuse tucked away somewhere else?
 

·
Registered
Joined
·
478 Posts
There is a fusible link block directly on the positive battery terminal. There is 5 fuses inside. Seems like 120A fuse is blown... OR both 80A + 100A fuses... only one 100A fuse seems to be OK.
 
1 - 2 of 2 Posts
Top