Toyota RAV4 Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi guys,

I am new to the forum. Would like to get your advice about my problem. I have a Rav4 2.0 VVT-i (2002). The engine oil lamp turned on and I couldn't change the oil for like 5km. Then, I found a place where we can only add new oil. I checked the current oil in the engine and it seemed expired and we added 1L 10W40. First the lamp went off and then it turned on again. I drived 8km to the next station and we emptied the all oil and change the oil filter. We added 4L oil and nothing has changed at all. I decided to leave my car there and get it with tow truck to Toyota service.

What do you suggest? What might be the problem?

Thank you,
Tugberk
 

·
Registered
Joined
·
1,631 Posts
Welcome. I can't help you, but if you post this in the 2nd Generation area you might get a better answer and a solution.

Good luck!
 

·
Registered
Joined
·
9,070 Posts
If your RAV is equipped with an oil change needed warning light system, perhaps the light which is supposed to come on if the oil hasn't been changed after a certain number of kilometers have been driven was not reset after the oil and filter were changed.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Thanks for your suggestions guys. We found the problem in the crankcase oil filter. Because of the old oil, the crankcase oil filter was damaged and after some point the pump couldn't get enough oil to the engine. And at that point, oil lamp started to flash.

Thank you,
Tugberk
 

·
Registered
Joined
·
9,070 Posts
Let's hope that your engine wasn't damaged by the lack of oil being pumped . . . .
 
1 - 9 of 9 Posts
Top