Toyota RAV4 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I have 2009 Toyota RAV4 4WD Sports Type. The four wheel drive light in the dashboard is On and Off. Can you help please what is the problem? Thanks
 

·
Super Moderator
Joined
·
10,002 Posts
The 4WD light is an error indicator. The cases I've seen here are arising due to overheating the electro-coupler on the rear differential. Could that be your issue?
 

·
Registered
Joined
·
41 Posts
maybe abs sensore? the 4wd system uses the steering wheel position sensor and abs sensors to know if the wheels spin in an different speed and calculate how much % of power to send on rear axle, when the front wheels start to spin faster then the rears, if any of the sensors is damaged, it will disable the 4wd system


The only time i have seen my 4wd off light come on was when the voltage regulator in the alternator started to go bad. it give the battery 15,8V overcharge and that messed the electronics and the car started to shut down abs, power steering, trac control and 4wd
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,643 Posts

·
Registered
Joined
·
1 Posts
Mine came on because of the tires. I'd blown one late in the winter and used a tire that was VERY close but not exactly the same size. Took it to the dealer and they said it was the problem. When I put my summer tires on I didn't see it again.

I should add that it would take a couple of minutes driving before the 4wd light would come on. Not sure if that is what you're experiencing.
 

·
Registered
Joined
·
2 Posts
Exactly what I had. Light 4wd came on every time after 5 min drive. After turning car on and off the 4wd light turned off again. After reading this post I checked the rear tires which were just replaced. Turned out they put 225/60 tires on instead of 225/65r17.
The system apparently noticed the rear wheels spinning faster than the front ones.
 

·
Registered
Joined
·
2,488 Posts
Exactly what I had. Light 4wd came on every time after 5 min drive. After turning car on and off the 4wd light turned off again. After reading this post I checked the rear tires which were just replaced. Turned out they put 225/60 tires on instead of 225/65r17.
The system apparently noticed the rear wheels spinning faster than the front ones.
So, back to the tire place?
 

·
Registered
Joined
·
2 Posts
Just returned from the tire shop. They replaced them with the correct ones.
Just yesterday I pinched one of the brand new ones with a big screw I picked up on the road. So they weren't happy to take it back but realized they had no other choice. The receipt stated the right ones and they put on the wrong ones.
4wd light doesn't come on anymore while driving. Hooray.
 
1 - 8 of 8 Posts
Top