Toyota RAV4 Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Looking for some help on an issue with my rav. There is a "clunk" at low speeds when going over bumps coming from the front driver side of the car.

So a bit of backstory: I replaced all suspension parts this spring myself. (Complere strut set, sway bar links, sway bar bushings, control arm, ball joints, tie rod ends, etc etc). Had some clunking issues from the rear, both sides; after, as well as a very sporradic clunk from the front driver side. Brought it into my mechanic and had him look over it, even had him look at my handywork in the front as I just wanted to be sure. Found out I screwed up the washer combination when mounting the rear shocks so was able to fix that but he said my front end looked perfect and he saw no issues.

Through the summer I noticed that the sporadic clunk occurred more frequently when it was wet out. It was especially noticeable when at one point I was moving and had a large amount of weight in the rear of the vehicle thus raising the front end up. After this I put it on stands and checked everything thoroughly and did not find any play or overt looseness. Didn't retorque anything just made sure nothing was clearly loose. Also added grease via the zerk fittings on the sway bar links in case that was an issue.

It's gotten more and more frequent, I've noticed it happens mostly when I go over uneven bumps and ESPECIALLY when the wheel is turned left when going over these bumps. When it's turned right, even slightly, the clunk is minimized if not completely mitigated

My current thought is that the sway bar links are loose on that side. I'm planning on throwing it up on stands in a few hours and tightening the links as well as greasing the links again. Hopefully this will resolve the issue but wanted to check with the more experienced folks here to see if you all have any additional input for me. Am I missing anything obvious? Could there be another reason for the clunk? Any explanations for the increase of the clunk when wet?

All help is appreciated! Once again it's a 2003 rav4 awd, 197k miles, and has recently installed kyb struts, moog sway bar links, moog ball joints, moog tie rod ends, oem control arm, oem sway bar bushings. If any of that helps hah.
Thanks!
 

·
Registered
Joined
·
3,689 Posts
The only other thing missing from your list not done is strut mounts which could be a possibility. You said you done the rear shocks and rear stabilizer links I believe?
 
1 - 2 of 2 Posts
Top