Toyota RAV4 Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I have 2009 RAV4 and it seems the Wipers are not functioning. When I turned it on from lowest to highest including switching the mist/int etc, the wipers were not moving or wiping? I have checked the fuse and all okay. I have retightened also the bolts. I can hear the motors are on. Rear wiper was okay. What seems to be a problem? Your assistance is greatly appreciated as winters and raining are approaching. Thank you so much!!
 

·
Premium Member
Joined
·
2,505 Posts
Check the wiper bolts. They are at the base of each blade holder. There is a known risk of them becoming rusted and not holding onto the wiper shaft. They should turn when the wipers are on.
.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
I have retightened that bolts also for both sides, and still not works. I guess not on the bolts. Any other idea please? Thanks
 

·
Registered
Joined
·
8,737 Posts
Is it possible to move the wipers across the windscreen manually while the wiper switch is in the Off position?
 

·
Registered
Joined
·
1,447 Posts
if you hear the motor running but the wipers dont move then most likely the "wiper transmission" is broken or unhooked...google that and you can find more information on it...i have had them break or disconnect before tho not on my rav...
 

·
Registered
Joined
·
1,064 Posts
There is a Safety Recall for North American produced 2009-2012 RAV4 for windshield wiper motor link. Corrosion can cause 'separation of the wiper link from the wiper motor crank arm' which would make the wiper inoperative. Might be your problem? Toyota is sending out letters about this now, and/or check your vehicle on the Toyota.com/owners website to see if it is affected.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #7
Is it possible to move the wipers across the windscreen manually while the wiper switch is in the Off position?

Yes. When the engine and the switches are on/off for the Wiper, I can manually move the wipers across the windscreen. What's the problem on that please? Tks.
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,832 Posts
Yes. When the engine and the switches are on/off for the Wiper, I can manually move the wipers across the windscreen. What's the problem on that please? Tks.
As rav4system alluded to in his post, it sounds like the little gearbox inside the motor has stripped out or broken. I'm sure replacing the wiper motor will fix it.
 

·
Registered
Joined
·
1,064 Posts
As rav4system alluded to in his post, it sounds like the little gearbox inside the motor has stripped out or broken. I'm sure replacing the wiper motor will fix it.
So, take it to dealer and be sure to find out if this is related to the Safety Recall of the wiper motor linkage corrosion. If so, they are obliged to fix it for free. (That is, if they have a fix, lol. Got my letter from Toyota yesterday about this.) Let us know how it goes.
 

·
Registered
Joined
·
1,447 Posts
The OP checked the fuse BUT there might be a wiper relay and it should be checked.
the op said that he can manually move the wipers with his hands...and he hears the wiper motor working...that means that something is broken somewhere between the wipers and the motor...probably associated with the recent safety recall...
 

·
Registered
Joined
·
253 Posts
There is a Safety Recall for North American produced 2009-2012 RAV4 for windshield wiper motor link. Corrosion can cause 'separation of the wiper link from the wiper motor crank arm' which would make the wiper inoperative. Might be your problem? Toyota is sending out letters about this now, and/or check your vehicle on the Toyota.com/owners website to see if it is affected.
Hi. This is Rip Van Winkle calling to say I must have missed something.
Can someone link me to a Canadian Toyota recall/repair statement, please?
I'll talk again on Feb 2, since I'm planning to go undercover until then. :surprise
Thanks
 

·
Registered
Joined
·
253 Posts
Thanks, Rick.
I'm usually all over these Toyota recalls, but I missed this one.
I'm happy that I don't have to go back for yet another one.
I still have the clockspring to do, and the rear suspension epoxy thingies, but I'm going to pass on the latter, until Toyota comes out with a DECENT fix.
Anyway, thanks again, and I'll see you in the waiting room!
Dave
 

·
Premium Member
Joined
·
172 Posts
Do this first: take one of the wiper blade arms off the drive spindle (outside). While the arm is off the drive spindle, run the wipers and see if the spindle is turning. The drive spindles fit into the arms with a spline-to-groove fit. Sometimes if the wipers are frozen to the windshield (windscreen, for our UK drivers) and the wipers are turned on, it strips out the splines as the arms don't move. If the spindles are NOT moving, the problem is deeper into the system, as outlined above. What if they are stripped out? A quick fix is to take a dab of valve-grinding compound and smear it on the spindle, then torque the arm back on. The long-term fix is have them replaced: it can be either the splines in the wiper arm OR on the spindle so check both. The spindle will be tougher metal than the wiper arm meaning the arm will strip out first. The fix will then be just replacing the arm. Here's hoping it is as simple as that......
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,832 Posts
I hope Horse4190 comes back and lets us all know what the problem turned out to be.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #17
I just came back from the dealership to check my wipers that are not working. No issues with the Wiper Bolts at the bottom of the cowel and not seized. Fuses have been checked and good. They want to have another diagnosis and charging me around $120 to check. Is anybody know what might be the problem is - do you think the Wiper Motor or Wiper Transmission?? When I put the switch it ON, I can hear the motor is running but not wiping accross the windshield. I'm trying to get a away with their diagnosis and save a bit. Appreciate your help please. Thank you
 

·
Registered
Joined
·
1,447 Posts


the blue arrows point to where the wiper arms connect....the red arrow points to where the transmission connects to the motor...at the end of the black bar there is a "ball and socket" connection to that small silver piece that is bolted to the wiper motor...it looks like a white piece of plastic...most likely the transmission has separated from the motor there...not hard at all to get at the wiper transmission to investigate...
 

·
Registered
Joined
·
24 Posts
Discussion Starter #19
Many thanks Rav4 system. Very helpful info. I will open this tomorrow and hopefully that's it. Looks like that is not part of the recall as the dealership here in Toronto area does not have the letter yet to their Rav4 customers.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #20
Rav4system is right. The bar is came out or separated from the Ball and socket connection. The dealership will charge me $120 just to diagnose. Its a rip off. Thanks again r4system. I think i need to replace the whole linkage or think something else on the socket screw it temporarily. Thanks
 

Attachments

1 - 20 of 23 Posts
Top