Toyota RAV4 Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter · #1 ·
Hi guys
I have been getting real good advice and feedback here like so many; this is a great forum. I hope u can help me out on this one.
recently had engine rebuilt (with a new timing chain kit, and rings) but the engine knocks and pings.
with premium gas, noise disappears. regular gas, its back. i put seafoam to clean injectors. but still noise there with regular gas.
a mechanic suggested the fuel injectors are leaking.
any other thoughts? advice?

much appreciated!
 

·
Registered
Joined
·
9,162 Posts
I don't know how "leaking fuel injectors," whatever that supposedly means, could cause the problem you are having. In pre-ECU days the pinging problem you are having could be caused by improper ignition timing or having a compression ratio which is too high for regular fuel. It is possible that the original computerized engine management system is not the proper one for your rebuilt engine. Other forum members may have other ideas.
 
  • Like
Reactions: ravi shankar

·
Registered
Joined
·
272 Posts
Timing chain tensioner in good condition?

View attachment 54930
I wonder if the timing chain tensioner was installed correctly when everything was put back together? sounds like the timing is advanced too much

if the chain were off one tooth, or the tensioner, which also advaces the timing weren't doing its' job correctly ....

not sure if that could cause the symptoms or not, but it is worth looking into

my opinion is that the leaky injectors is BS, if premium gas cures the problem, it sounds like a timing issue
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #7 ·
the guy that did it is a good guy with a good reputation
he did put a new timing chain kit and he has done so many engines before, i doubt that on mine he put it off somehow
thank you
 
1 - 7 of 7 Posts
Top