Toyota RAV4 Forums banner

1 - 6 of 6 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I have the OEM fog lamp for a 1996 2 door rav4 and I think I blew the fuse as both fog lamps are not working. Anyone know the exact location for that fuse? TIA
 

·
Premium Member
Joined
·
3,345 Posts
Hello m900s!

While sitting in the driver's seat (left hand drive models)... it should be located in the small fuse block in front of your left knee... blue 15amp fuse in the upper right corner of the block.



Where are you located? Back in 1996 I was one of only three or four people who installed these OEM fog lights for Toyota... for the NW states of the US :lol:

If you find the fuse is still good... check other connection points for maybe a loose plug or bad relay ---> http://rav4world.com/index/foglights.html <--- If it's a BAD connection... I didn't do it :roll:
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Hi kelly,
Thank you very much!! It's now working! I'm in New York , I have 150,000 miles on it. It 's a manual 2 door like yours. I uploaded the pics of my Rav at album.
nell
 

·
Premium Member
Joined
·
3,345 Posts
Nell - Glad to hear you got them working again. New York... guess I can't take credit for the install :lol:

Just to point out... and this appears to be a COMMON PROBLEM on our forums ---> You have successfully uploaded a GREAT looking photo of your RAV4, but you've uploaded it into our GENERAL RAV4.1 (1994-2000) section. If you click on the ALBUM icon directly under any of YOUR postings... you will see that you have your own PERSONAL ALBUM section that you can upload an aditional 16 photos into 8)
 

·
Super Moderator
Joined
·
1,554 Posts
Thanks for this info as well Kelly, I missed seeing the link... I will have to look into this myself... 8)
 
1 - 6 of 6 Posts
Top