Toyota RAV4 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I need help, I did the bonehead thing (positive battery post to negative wire) and blew the alternator fuse link, with some reference to posts here I was able to get the fuse replaced. It blew several other smaller fuses as well. I've replace all the fuses that I can see are blown. I've checked every fuse. The problem I have now is the 4wd light is on. I know this disables the 4wd system. I need help in trying to diagnose what to check next? The car runs fine otherwise. Everything else works and there are no codes stored. Anyone have any suggestions?
 

·
Registered
Joined
·
1,912 Posts
Which of the two 4wd related lights do you have on.





If it is the light in the first image, did you check the 4WD fuse, which is located in the cabin near the drivers left knee? It is shown as 3rd from the left in the top row in this image. It is a 7.5A fuse and is brown in color. If it is the light in the 2nd image, then make sure that you have not accidentally operated the 4wd lock switch on the dashboard.
 

·
Super Moderator
Joined
·
10,147 Posts
I've replace all the fuses that I can see are blown.
A fuse may have failed w/o looking blown. Either swap it with another or use a 12V test light to see if power is actually getting thru.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Its the regular 4wd light not the 4wd Low Lock light. Yes I checked the fuses under the dash., I had several blown there.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I'll recheck that fuse and see if that helps. It's possible as Dr. Dyno said it might be blown without looking blown. Thanks for suggestions,
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
It was the 4wd fuse. I didn't even know that fuse block existed. Lets just say that's a tough one to find for a big man. It's even harder to get into a position to remove and replace the fuse. Thanks again for all the help.
 
1 - 7 of 7 Posts
Top