Toyota RAV4 Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1 (Edited)
Hello fellow RAVers,

I am having issues when trying to program a new smart key for my 2017 RAV4 Hybrid Executive.

I am running Techstream on a Windows 10 64bit laptop.
I got the VXDIAG VCX NANO WIFI adapter (VXDiag VCX NANO for TOYOTA TIS Techstream V15.00.026 WIFI Version) and I have tried several versions of Techstream (mostly 13s 14s and 15s) but when I click next on either of the "Key Code Registration (Classic)" and "Key Code Registration" utilities, I get an error stating that the communication to some ECU is lost (see attached images).

Key Code Registration (Classic) error :
151050


Key Code Registration error:
151051


I already checked the possible causes (turned off cellphone, charged the auxilary (12V) Battery, car only has 2 registered keys (1 is lost), etc.

I am also not able to do the Key Code Erasure utility, same thing as soon as I click next, it shows the same communication error:
151056


The cable seems to work because I can connect to all the available ECUs the RAV4 has (here in Germany they are sold with no alarm aka "Theft Deterrent").
These are the ECUs after doing a Health Check, supposedly all white ECUs without an asterisc are available in my RAV4, those with an asterisc at the beginning of their name are not available, for example my RAV4 does not have a Moonroof:
151053


And the cable check utilty returns a mostly succesful test:
151054

Funny enough, the L line should be on PIN# 15 but that's not the case with my RAV4, I checked its DLC3 port and PIN# 15 is empty:
151055


I have been able to customize some functions, for example I change the Lane change blinker from 3 blinks to 4 blinks. I am also able to read TPMS sensors IDs and their reported values: Temperature and Pressure.

I can also program new TPMS IDs.

I have installed Techstream as a Standalone user, Authorized repairer (don't know if it makes a difference).

What do you think is the problem with my setup? Any thoughts are more than welcome.

Roberto
 

·
Registered
Joined
·
104 Posts
Hello fellow RAVers,

I am having issues when trying to program a new smart key for my 2017 RAV4 Hybrid Executive.

I am running Techstream on a Windows 10 64bit laptop.
I got the VXDIAG VCX NANO WIFI adapter (VXDiag VCX NANO for TOYOTA TIS Techstream V15.00.026 WIFI Version) and I have tried several versions of Techstream (mostly 13s 14s and 15s) but when I click next on either of the "Key Code Registration (Classic)" and "Key Code Registration" utilities, I get an error stating that the communication to some ECU is lost (see attached images).

Key Code Registration (Classic) error :
View attachment 151050

Key Code Registration error:
View attachment 151051

I already checked the possible causes (turned off cellphone, charged the auxilary (12V) Battery, car only has 2 registered keys (1 is lost), etc.

I am also not able to do the Key Code Erasure utility, same thing as soon as I click next, it shows the same communication error:
View attachment 151056

The cable seems to work because I can connect to all the available ECUs the RAV4 has (here in Germany they are sold with no alarm aka "Theft Deterrent").
These are the ECUs after doing a Health Check, supposedly all white ECUs without an asterisc are available in my RAV4, those with an asterisc at the beginning of their name are not available, for example my RAV4 does not have a Moonroof:
View attachment 151053

And the cable check utilty returns a mostly succesful test:
View attachment 151054
Funny enough, the L line should be on PIN# 15 but that's not the case with my RAV4, I checked its DLC3 port and PIN# 15 is empty:
View attachment 151055

I have been able to customize some functions, for example I change the Lane change blinker from 3 blinks to 4 blinks. I am also able to read TPMS sensors IDs and their reported values: Temperature and Pressure.

I can also program new TPMS IDs.

I have installed Techstream as a Standalone user, Authorized repairer (don't know if it makes a difference).

What do you think is the problem with my setup? Any thoughts are more than welcome.

Roberto
First issue: TS does not work on a 64 bit OS. You must run it on a 32 bit OS. I have it running on W10 32 bit.
Believe me, I have tried EVERYTHING to make it work under 64 bit. Anyone who says it does is BS. No one will supply details of their drivers. TS does work. However, it will not connect to the VCI/VCX under 64 bit OS. It is the TS interface to the driver. The driver (FTDI 2.12.28) is fine since it connects to the computer. This is all TS versions from 7.xxx to ver. 15.00.26. I have a MVCI and a VCX Nano. Neither work on 64 bit. Both work on 32 bit.
Once you are running on 32bits it is pretty easy.
I have just done that with my 2019 Camry. One thing: I needed to delete a key. When you do that ALL keys except the one you use to do the deletion are deleted. Why? I don't know. It seems like it is only deleting one. Maybe it was me. Then I had to add back in the other one. I bought the car with only one fob. The dealer finally came up with another. When I asked why they did not delete the missing one, they said they just don't do that. Like it was real difficult, NOT.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
Hi ruggb,

thanks for your reply, do you also use the VCX nano tool?

I read somewhere that the 32bit requirement is for the drivers of the cloned cables, not for Techstream.

I was able to customize some functions and even write TPMS IDs so I think it's working, just the Key programming thing is giving me problems.

Sent from my SM-G970F using Tapatalk
 

·
Registered
Joined
·
104 Posts
With 64 bit, mine will never connect to the ECU. If you have it connecting to the ECU, then I want to know EXACTLY which drivers and TS versions you have installed and which process you used to install all of them.
TS =
MVCI =
FDTI =
VCX Nano =
The disconnect from the ECU I have seen on mine and it appears to be a Windows issue. However, when it happened, reloading things seemed to fix it. I have not tracked that down yet.
 

·
Registered
Joined
·
203 Posts
First issue: TS does not work on a 64 bit OS. You must run it on a 32 bit OS. I have it running on W10 32 bit.
Believe me, I have tried EVERYTHING to make it work under 64 bit. Anyone who says it does is BS. No one will supply details of their drivers.
Sorry ruggb, but you'll get voted off the island with that attitude.

No, it wasn't straightforward, and I couldn't even guarantee that I could pull it off again. I had to get a little help from the package seller, but I did get it to work with Win10-64 on an older HP Dual Core laptop. I wiped the HDD and put a fresh image on the system, disabled Windows Defender, and this was the very first thing installed. I purchased from seller SZ-Tonda on Amazon. V14.30.023 Techstream software with a supposedly Mini VCI V2.0.4 cable (catch: it loaded V1.4.6 drivers, so I suspect that the cable claim was 'inflated'). But it worked....

His ad was different from most. No 'universal cracked keys'. You loaded the software, initiated it and got a return code, sent it to him, and he sent a custom key for the install. That might mean it will never load again.... but the first thing I did was make a complete backup of the HDD after getting it working, so I do have a restore point.

And I did successfully create a Smart Key for my 2015 Toyota Sienna Limited Premium. I'm the moderator on SiennaChat (another AutoGuide / Verticalscope property), so please tread carefully before calling BS on this claim!

I have not tried connecting to my kids RAV4, but I wouldn't expect it to respond differently from the Sienna (but who knows....).
 

·
Registered
Joined
·
104 Posts
no attitude intended. I am just frustrated as hell. I have done everything that you mentioned. EXCEPT, I do not have MVCI 2.0.4. The latest I have found is 2.0.1. Guess I have to search for that one. I assume the FTDI driver you are using is 2.12.28, correct? I have used 14.30.023 previously. All the latest TS versions I used have been avtivated with a code. Thanks for the info.
 

·
Registered
Joined
·
1,432 Posts
Many threads here showing how to install on Windows 10 64bt.with the mini vci cable purchased on eBay.

I have it running right now. No problems.

I even have it on an old NETBOOK but it runs real slow.
 

·
Registered
Joined
·
104 Posts
\
Many threads here showing how to install on Windows 10 64bt.with the mini vci cable purchased on eBay.

I have it running right now. No problems.

I even have it on an old NETBOOK but it runs real slow.
Two questions:
1. does firmwareupdatetool run?
2. which f/w version is your minivci?
 

·
Registered
Joined
·
33 Posts
Discussion Starter #10
does anyone know what's the ECU Key button and ECU Security thing? (circled in red) how do I enable the buttons?

I read that there are three different subscriptions types of Techstream; standard, professional diagnostic and security professional.
"
Three subscription types are available so you can choose the level of support needed
* Before purchasing a Security Professional subscription, you must be a current member of the NASTF Vehicle Security Professional Registry.
"
attached image.
151138

how does that work? are there 3 different installation files for Techstream or is it tied to the account?
to register a smart key I need the security professional? :/
can someone help me with this?

Thanks
 

Attachments

·
Registered
Joined
·
1,432 Posts
does anyone know what's the ECU Key button and ECU Security thing? (circled in red) how do I enable the buttons?

I read that there are three different subscriptions types of Techstream; standard, professional diagnostic and security professional.
"
Three subscription types are available so you can choose the level of support needed
* Before purchasing a Security Professional subscription, you must be a current member of the NASTF Vehicle Security Professional Registry.
"
attached image.
View attachment 151138
how does that work? are there 3 different installation files for Techstream or is it tied to the account?
to register a smart key I need the security professional? :/
can someone help me with this?

Thanks
I never used the wireless cable you have


This is the one most people on this site use installed on their laptop.

Is your main goal to just make an extra key?

 

·
Registered
Joined
·
33 Posts
Discussion Starter #14
Could someone take a picture of their DLC port (also refered as OBD-II port) so I am able to compare the PIN layout?
I find it funny that there is no terminal on PIN 15 ("L Line" which has to do with Programming).
 

·
Registered
Joined
·
1,432 Posts
You might want to find a forum in GERMANY. Your Rav may be different from the North American versions seen mostly here.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #16
According to the seller I need an original online account, is that so? I doubt all the people using the minivci clone cables have original online account...

btw, apparently when you want answers from the seller you have to be rude hehehe I gave them a full week to answer my question so I had to ask "George" for help.


Sent from my SM-G970F using Tapatalk
 
1 - 16 of 16 Posts
Top