Toyota RAV4 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
389 Posts
Discussion Starter #1
I've got a 2009 Rav4 Sport 2GR-FE V6 with the U151F AWD transmission. I've used TorquePro in the past with my two prior Prius but this is the first time trying to locate custom PIDs for the Rav4.

Through googling I've gathered that the PID for transmission temperature is not built in to default PIDs and it has to be created. The only help I could find on Toyotas were from older Rav4s and a few Tacoma and Highlander forums.

For creating the PID all of them had pretty much the same values but none seem to be accurate - here is what i tried so far...

1) For pre 2010 models
21D9
Long Name: whatever you want
Short Name: whatever you want
Min Value: 0
Max Value: 300
Scale factor: 1
Unit type: °F (different formula for °C)
((((E*256)+F)*(7/100)-400)/10)

OBD header to use: (left blank)
2) For 2010 and newer
2182
Long Name: whatever you want
Short Name: whatever you want
Min Value: 0
Max Value: 300
Scale factor: 1
Unit type: °F (different formula for °C)
((((A*256)+B)*(7/100)-400)/10)
OBD header to use: (left blank)

#1 provides an erratic output that jumps all over the place. #2 temperature seems to low (others have said roughly 50 degrees above ambient temp is typical.

Has anyone done this on the same gen and year Rav4 as mine and what did they do to get it to work?

Thanks!

Sent from my SM-G870W using Tapatalk
 

·
Registered
Joined
·
138 Posts
Tek, I found a successful PID for the pan temp that works with Torque Pro for my 2007 V6. I can't find it right now, but I'll look for it and get back to you here. BTW, my 2007 must have only the pan sensor and not the torque converter sensor as well.
 

·
Registered
Joined
·
389 Posts
Discussion Starter #3
Tek, I found a successful PID for the pan temp that works with Torque Pro for my 2007 V6. I can't find it right now, but I'll look for it and get back to you here. BTW, my 2007 must have only the pan sensor and not the torque converter sensor as well.


Great! Thx!! Looking at adding an aftermarket transmission cooler now that I’m running higher RPMs with my R9KTuned ECU.

Looking to add one based off the Highlander setup.



Vs the RAV4 setup looks like it would be an easy add-on.

 

·
Registered
Joined
·
138 Posts
Tek, I may have spoken too soon about being able to find that PID. I've looked at the app in my phone, but I can't find the PID settings I'm using. Sounds like we found the same threads in our searches. Have you seen this one?
Getting Transmission Fluid Temp using Torque Pro for Android - Toyota Nation Forum : Toyota Car and Truck Forums

I'm going on memory here, but I think this is the one I used. I'm irked with myself because I was sure I had saved those values somewhere, but today they are nowhere to be found on my computer or in my Rav file.

This past summer my ATF temps were running about 190-200F during freeway driving and not towing. I haven't tested yet while towing. The ATF and engine coolant were both close to ambient after a night in the garage.
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,639 Posts
Yeah, this first one works fine on my 2008:

If you are using the Torque app for monitoring transmission temp:


For pre 2010 cars (all equations copied from the thread at the Torque forum)


In Torque enter:


OBD2 Mode and PID:
21d9
Long Name:
Transmission Fluid Temperature 1 (or what you like)
Short Name:
Trans 1
Minimum Value:
0.0
Maximum value:
300.0
Scale factor:
x1
Unit Type:
°F (or alternatively C is you use the second equation below)


Equation:
((((E*256)+F) * (7/100) - 400)/10) - for output in F




or alternatively




(((((E*256)+F) * (7/100) - 400)/10) - 32) * (5/9) - for output in C




OBD Header to use:
left blank


For 2010+ cars (do not own one, so I have not tested this)


OBD2 Mode and PID:
2182 (NOTE DIFFERENT PID for newer Toyotas)
Long Name:
Transmission Fluid Temperature 1
Short Name:
Trans 1
Minimum Value:
0.0
Maximum value:
300.0
Scale factor:
x1
Unit Type:
°F
Equation:
((((A*256)+B) * (7/100) - 400)/10)




you can also convert this equation to C as above






OBD Header to use:
left blank
 

·
Registered
Joined
·
1,477 Posts
Great! Thx!! Looking at adding an aftermarket transmission cooler now that I’m running higher RPMs with my R9KTuned ECU.
-do you have the towing package with the bigger ATF cooler?
-I would wait to actually have a baseline of the ATF temps before actually starting to think of getting a new cooler. my temps where really good until I started towing a #3000 travel trailer.

-why would an ECU retune cause higher transmission temps?
 

·
Registered
Joined
·
389 Posts
Discussion Starter #8
-do you have the towing package with the bigger ATF cooler?
-I would wait to actually have a baseline of the ATF temps before actually starting to think of getting a new cooler. my temps where really good until I started towing a #3000 travel trailer.

-why would an ECU retune cause higher transmission temps?

No, my Sport didn’t come with the bigger alternator, radiator or oil cooler.

My Rav4 is now revving to 7200, tunes with more fuel and increased timing - making more power than stock, which may generate more heat.. I would prefer to be safer than sorry, when I’m at a track - beating it up on the RAV4.
 

·
Registered
Joined
·
1,477 Posts
No, my Sport didn’t come with the bigger alternator, radiator or oil cooler.

My Rav4 is now revving to 7200, tunes with more fuel and increased timing - making more power than stock, which may generate more heat.. I would prefer to be safer than sorry, when I’m at a track - beating it up on the RAV4.
if you want more safety for the track, start by changing the atf for something better than Toyota WS atf... (redline, amsoil or other full synthetic) WS doesn't like abuse.
 
  • Like
Reactions: TEKSMRT

·
Registered
Joined
·
389 Posts
Discussion Starter #10
The pre - 2010 PID (top TransTemp) bounces around with RPM. The post - 2010 PID (bottom TransTemp) appears to be working.

Does the bottom temp look correct with the ambient temperature?




 

·
Registered
Joined
·
1,477 Posts
sounds about right. on mine it will get to about 150-160F after about 20-30minutes with an ambient of around 70F, but I have the stock cooler and aftermarket.

goes up to 225F when towing, imagine without the extra cooling
 
  • Like
Reactions: TEKSMRT

·
Registered
Joined
·
653 Posts
Thanks guys. Going to add this to my toolkit.
 

·
Registered
Joined
·
571 Posts
For 2010+ cars (do not own one, so I have not tested this)


OBD2 Mode and PID:
2182 (NOTE DIFFERENT PID for newer Toyotas)
Long Name:
Transmission Fluid Temperature 1
Short Name:
Trans 1
Minimum Value:
0.0
Maximum value:
300.0
Scale factor:
x1
Unit Type:
°F
Equation:
((((A*256)+B) * (7/100) - 400)/10)

you can also convert this equation to C as above

OBD Header to use:
left blank
Thank you, I could not find this for 2010+ models anywhere else, only the pre-2010.
I inputted the formula and it seems to be working on my 2011.
The Torque indicated transmission temperature was climbing steadily while I drove in my neighborhood, up to 145 deg F. While idling, I measured with a IR/laser gun the temperature of the upper transmission hose that goes to transmission (outlet of transmission) and it indicated 155 F. Makes sense that the outlet of the cooler, that drains into the transmission pan, to be lower by a few degrees. I will test it on highway more. It's already hot outside.

Later I checked the formula against Techstream. Techstream transmission temperature was showing 158.5F. Yanked the adapter out, plugged in the Torque adapter (BAFX) and the PID formula for 2010+ reading was 160.5F. I would say that's darn close.



As a side note, with the hood open, and both cooler fans spinning fast (AC engaged), I noticed that a huge amount of heat is blasted straight into the battery. I measured 145 F on it's face... I wonder if I can do something about that.
 
1 - 13 of 13 Posts
Top