Toyota RAV4 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi. I’ve seen this several times with no fix posted. Currently having a mare with a recently purchased 2002 d4d and a stumped mechanic. And at a point where I either sell or plow more money in and risk no not fixing the problem. Very frustrating


Has anyone got to the bottom of the hot start problem yet? I recently bought a mk2 d4d. Exact same trouble. Test drive it fine. Got it home. Wouldn’t start when hot. Just had new crank sensor fuel filter and oil done. No better. The turbo is leaking oil. But reluctant to fit a new one if I can’t sort the starting problem. I’m getting the starter tested hot/cold starts as this seems to have been suggested a lot. The next on list from the garage was an ecu which is in order. Then I’m at a loss. One suggestion was oil from turbo getting into the cylinders or injectors leaking inside massively. I don’t want to replace so many parts as a process of elimination and not fix the problem. It still woukdnt start with Brake cleaner sprayed into it which the technician found strange. Any info welcome.
tia
 

·
Registered
Joined
·
21 Posts
It looks like you have the diesel model which was never sold in North America, where this forum is based. You'll probably have better luck getting useful responses on other Toyota forums with international coverage.
 

·
Registered
Joined
·
21 Posts
Ok sorry. Thought I read an article on the forum with the same issue.
It's very possible, there was a similar post recently and it received the same answer. You can use the forum search to look for other posts and threads with the same or similar topics.
 
1 - 4 of 4 Posts
Top