Toyota RAV4 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
My 4 cyl accelorates very slowly and loses speed up mountains ... even the lowly Berkshires. Scared to take her cross country! Is this normal?

Anyone have experience dropping a new engine in? What range does this run for labor / materials if you know? I'm not looking for anything fancy, just want some pep.
 

·
Super Moderator
Joined
·
11,110 Posts
Is it a secret which engine you have and how many miles are on it? Has it been serviced on a regular basis?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Only a secret to me! Well, the issue has been since I had the car at 45k now at 80k. I have changed the oil regularly, the air filter, the tranny fluid once or twice. The 02 sensors are out. Mileage is 25 mpg highway, so I have not done the repair (scared of having to thread aluminium, or anything for that matter).

It's the smallest engine, I think it says 2.0 on the top. I'll check it next time I am in the garage.

Tires are have been replaced twice, and are now new.

I should add I am not scared of it breaking down, just not making over the Continental Divide!
 

·
Super Moderator
Joined
·
10,147 Posts
I'd suggest you find a level road and time a few full throttle 0-60 mph runs. I'd guess they should be in the 10-11 second range if the engine is running right.
I did it for a friend who thought her aging Honda Accord didn't have power anymore. Sure enough 10 seconds. I told her to push the pedal on the right harder and the car would go.
BTW, what year is the car. That'll tell us what engine it has.
 

·
Registered
Joined
·
1,912 Posts
The 02 sensors are out. Mileage is 25 mpg highway, so I have not done the repair (scared of having to thread aluminium, or anything for that matter
Do you mean to say that you have no O2 sensors installed at all, and you just have the open holes in the manifold where they once were ?

If that is the case, then there is no surprise why your engine is not performing at maximum efficiency.
 

·
Super Moderator
Joined
·
10,147 Posts
Agreed, whatever "the O2 sensors are out" means must have the check engine light (MIL) on. Possibly a Malfunction Indicator Light might be clue to the engine not running right???
 
1 - 6 of 6 Posts
Top