Toyota RAV4 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
i have rav4 2008 my car was shaking in d i clean the throttle body the shaking is gone but now I hear the sound of rumbling in the car when Speed ​​switch to the second , third and fourth gear , i change the spark plug and, i cleaned injectors, But to no avail, i check the computer but not codes appear.
any advice
 

·
Registered
Joined
·
7,917 Posts
Can you tell us more about the rumbling? What speeds? Only when you accelerate?
Does the noise come from front, back, middle?
Have you tried rotating the tires?
How loud is that rumbling?

Maybe put a video on youtube or find one similar to yours on youtube and post a link here.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Can you tell us more about the rumbling? What speeds? Only when you accelerate?
Does the noise come from front, back, middle?
Have you tried rotating the tires?
How loud is that rumbling?

Maybe put a video on youtube or find one similar to yours on youtube and post a link here.
yes i hear the sound only when car accelerate , sound came from the gear box i guess , i tried rotating the tires, its not load ,it' like grrrrr just when accelerate.
 

·
Super Moderator
Joined
·
9,555 Posts
Bad muffler?
 

·
Registered
Joined
·
1,064 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #6
When accelerating at low rpms under load (not pressing the pedal enough for the auto to switch gears), the engine makes a sound. I've always maintained my engine well so I'm not sure what it could be. I have a new Toyota air filter, new NGK factory replacement spark plugs that are pre-gapped, new NGK spark plug wires, throttle body and MAF sensor cleaned and it still makes the marbles in a can noise (I also sea-foamed it before changing the spark plugs). Going up to 89 octane helped a bit, but this feels like a bandaid solution covering up another problem.
 

·
Registered
Joined
·
641 Posts
When accelerating at low rpms under load (not pressing the pedal enough for the auto to switch gears), the engine makes a sound. I've always maintained my engine well so I'm not sure what it could be. I have a new Toyota air filter, new NGK factory replacement spark plugs that are pre-gapped, new NGK spark plug wires, throttle body and MAF sensor cleaned and it still makes the marbles in a can noise (I also sea-foamed it before changing the spark plugs). Going up to 89 octane helped a bit, but this feels like a bandaid solution covering up another problem.
"Marbles in a can noise"? Classic sign of a water (coolant) pump going bad. You should have that checked out. The noise will get progressively louder as the impeller shaft bearing is getting worse.
 

·
Registered
Joined
·
387 Posts
I've been having same thing. most notable when cold and taking off. Like the tire treads are rubbing on the car.
A rumbly vibration that feels like it's coming from near the front. I'm going to check the u joints, differential, and transfer case. I hope it's not the transmission.
 

·
Registered
Joined
·
3,267 Posts
I've been having same thing. most notable when cold and taking off. Like the tire treads are rubbing on the car.
A rumbly vibration that feels like it's coming from near the front. I'm going to check the u joints, differential, and transfer case. I hope it's not the transmission.
It could be the u-joint and the rear u-joints usually goes first. The only thing you can do is monitor to see what speed it happens and how often.
 
1 - 9 of 9 Posts
Top