Toyota RAV4 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi All,

I have a 2007 Rav4 with the 2.4, and quite randomly it chooses to crank over but not start. The majority of the time it starts wonderfully with no issues, but sometimes it just cranks and cranks to no avail. If I wait for a little while, the issue usually remedy's itself and its able to start. I have noticed that it seems to happen randomly if I have recently turned the car off, and then try to start it again ( like going to a store for a few minutes and leaving). Its not throwing any codes anymore, I replaced everything the codes said to replace. Any help would be much appreciated.

Thanks!
Rob
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,761 Posts
Do you have the Security light to the left of the clock? If it's flashing, the immobilizer will not let the engine start.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Do you have the Security light to the left of the clock? If it's flashing, the immobilizer will not let the engine start.
Nope, the security light is not flashing. If the light was flashing however, would the car still start after a while even though the security is preventing it?
 

·
Registered
Joined
·
1,660 Posts
My last Ford (*ever*) had issues that sounded very much like that. It turned out to be a bad fuel pump.

You may have a similar issue, or possibly a clogged fuel filter?

.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
My last Ford (*ever*) had issues that sounded very much like that. It turned out to be a bad fuel pump.

You may have a similar issue, or possibly a clogged fuel filter?

.
I really hope its not the fuel pump, although I have been suspecting it is. The fuel filter is attached to the pump which is in the tank, so i'm screwed both ways haha.
 
1 - 5 of 5 Posts
Top