Toyota RAV4 Forums banner

1 - 6 of 6 Posts
R

·
Guest
Joined
·
0 Posts
Discussion Starter #1
:cry: Well at 36K my RAV4 has gone wrong yet AGAIN!!!!!!

The Check Engine Light has come on. I took it to a dealer who quoted £76 just to hook it up to the machine for diagnosis! He said it may just be a glitch in the computer and need just need resetting - (an expensive glitch which I resent paying for!

I declined the offer and decided to look here first for any help and am slightly encouraged to find that I am one of many suffering this problem!

I see that people in the US have been saying that their RAV's are covered by an Emissions Warranty - I've checked my warranty booklet and can only find a 3yr general/surface rust paintwork (which it is now over/expired) and a 12yr corrosion performance warranty.

There is no mention of anything else being covered.

The light disappeared for a couple of days but is now back on. My initial thought was that it is some sort of ploy by Toyota to get me back in the garage as it was due a service a couple of months ago and I haven't been able to have it done yet!

I just know this is going to work out expensive.

Does anyone in the UK know if there are garages around that will do the initial diagnosis for free?

I haven't been on here for a while and am amazed at all the problems that seem to be cropping up (especially the poor person who has had to have a complete new engine on a 2yr old car!)

For anyone who's interested in the cars repair history so far (or anyone who has ALLOYS):
I've had creaky suspension which they kept wrongly diagnosing (suspension arms replaced twice, plus other parts replaced along the way). As usual I was fobbed off with various excuses until over a year later and very dissatisfied I took it to Toyota HQ. Only THEN did the dealer take me seriously and manage to fix it (although it's still a little creaky).
I also have dash rattle but will have to live with that.
ALLOYS - I noticed 'spots' on my alloys and discovered that they were suffering from signs of corrosion. This is one thing that my local dealer was brilliant about and replaced them immediately with a complete new set covered under the warranty.

If this latest problem turns out to be expensive then I think it will be the last straw.

I will keep you posted! And any advice on the Engine Light would be gratefully receieved!

Ribena
 
N

·
Guest
Joined
·
0 Posts
Discussion Starter #2
I had the light came on, but not for emmision problem. I have failed ignitors module in the spark plugs. But if you go to another dealer they might provide a free diagnostics. I had mine dignosed free when I changed the ignitors.

I have a question for you on the ALLOYS. My alloys too are all corroded. When you said your dealer will replace them were this under the 3 yrs warranty or the 6 yrs anti-corrosion warranty?

My car is almost 5 yrs old, so I wonder if its still under warranty.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Corroded Alloys

Hi Nomoretoy

I'm not sure which part of the warranty they came under - I'm not sure that they would be covered under the 6yr one as reading through it seems to be only actual body parts and I don't know whether alloys would be classed as a decorative thing - it's definitely worth a try though.

At the time I asked if I would have the same problem in another couple of years time but they said that Toyota had since changed the formula for the alloys and there was no longer a problem????!!!!! (which implies that all UK 2001 models will suffer this problem!). When I had the repair invoice through it listed the alloys at well over £1000 (although I obviously didn't have to pay anything), so it's worth asking your dealer.

Re: the engine light.

Some days it's on, some days it's off!!!!!! I'm assuming that it can't be anything serious otherwise it would stay on all the time and I would notice a difference in the driving.

My exhaust is a bit 'bubbly/farty' so I don't know whether that needs checking and whether that may affect the light. (Not exactly engine but emmissions related and all that!).

Good luck with your alloys. It's a shame this beautiful car has so many quirks!
 

·
Registered
Joined
·
147 Posts
It could be this, the same thing happened to me....... Almost all new cars now have the same problem, and it's VERY common. All it is is that there is a sensor that has a very small margin of error and when the info it's processing goes "out of bounds" even just a little, the computer sends out the check engine light signal. The computer just needs to be reprogrammed to widen the margin a bit. The engine light must be on for the shop to do this, and it takes about an hour, however, here in Switzerland it's covered by warranty and absolutely free. There is no risk in driving with the check engine light on if this is what the problem is, and after only 30 something Kms.... I'm pretty sure you're experiencing the same thing I went through. The sensor can also be reset at the shop in about 2 minutes, they plug a little machine into your car inside beside the clutch, and the engine light turns off. It may come back on at any time though, as the factory settings are not re-programmed (widened), only reset. Or you could try unplugging the air intake sensor wiring harness (there's a clip-plug) for a few minutes..... plug it back in and restart the car. That worked for me. But the next time the light goes on, I'm going to get the 'puter re-programmed. Ask a Toyota dealer about re-programming code 141 on the on board computer because of the check engine light and see what they say. Everyone here knew exactly what it was as soon as I called them and told them about the light. Don't forget to insist on warranty! Good luck, I hope that's all it is!! Peace, Jamie.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #5
reply to Heinz (light back off today-hooray!)

Heinz

It's definitely not covered under warranty as it's over 4yrs old with 30K (36,000 miles not 30km).

Light has gone off again and there is still no difference in the driving so I'm not too worried about it.

The only thing I have been making sure I do is turn the petrol cap until it clicks as someone suggested. The ligth has been going on and off so I don't know whether this helps of not .

Unfortunately I can't just ask them to hook it up to the computer as they will charge a lot of money for this simple request so it will have to wait!

Tina
 

·
Registered
Joined
·
147 Posts
oops, my bad on the Kms! But if it helps, the guy here told me mine would probably go off and on too. In reality it was on, they hooked up their machine, and it went off........it went on again about an hour and a half later, and then it went off again after I unpluged the air intake sensor and pluged it back in a few minutes later....... it's stayed off now for about a month I'd say When/if it does come back on I'm going to get my 'puter re-programmed....... but I've still got warranty. In any case, they said it's not at all harmful to the car..... it's just a glitch in the system. Hope that's all you have!
 
1 - 6 of 6 Posts
Top