Toyota RAV4 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
2017 RAV4 Platinum JBL Entune radio has static

I just bought a 2017 Toyota Rav4 AWD Platinum. I love the vehicle, but I have two problems. The sunroof only works sometimes, most times I have to disconnect the negative on the battery and reconnect in order to close the sunroof (got an appointment in two weeks with Toyota) and the Entune audio system.
When I seen my stereo was actually a JBL, I was quite excited, that was until I paired my iphone SE with the unit. The music is hit or miss. When playing music from the phone, sometimes (rarely), it sounds great, most times there is static. Even when it does sound okay, all I need to do is make a phone call through the sound system and the buzzing starts. Very annoying, and I haven't seen this problem anywhere else. anyone have any ideas?
 

·
Registered
Joined
·
49 Posts
I just bought a 2017 Toyota Rav4 AWD Platinum. I love the vehicle, but I have two problems. The sunroof only works sometimes, most times I have to disconnect the negative on the battery and reconnect in order to close the sunroof (got an appointment in two weeks with Toyota) and the Entune audio system.
When I seen my stereo was actually a JBL, I was quite excited, that was until I paired my iphone SE with the unit. The music is hit or miss. When playing music from the phone, sometimes (rarely), it sounds great, most times there is static. Even when it does sound okay, all I need to do is make a phone call through the sound system and the buzzing starts. Very annoying, and I haven't seen this problem anywhere else. anyone have any ideas?
There is a software update meant to fix this
I just bought a 2017 Toyota Rav4 AWD Platinum. I love the vehicle, but I have two problems. The sunroof only works sometimes, most times I have to disconnect the negative on the battery and reconnect in order to close the sunroof (got an appointment in two weeks with Toyota) and the Entune audio system.
When I seen my stereo was actually a JBL, I was quite excited, that was until I paired my iphone SE with the unit. The music is hit or miss. When playing music from the phone, sometimes (rarely), it sounds great, most times there is static. Even when it does sound okay, all I need to do is make a phone call through the sound system and the buzzing starts. Very annoying, and I haven't seen this problem anywhere else. anyone have any ideas?

Sent from my Nexus 6P using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
I had the vehicle in to Toyota on two separate occasions. The first time, they did find the problem with the radio, a faulty sunroof switch. The switch was changed, and the radio was fine. Must have been a short. However, changing the switch still didn't fix the sunroof. It still only works 'sometimes', which is as bad as never working. I am scared to open it in fear I will be caught in the rain.


The technician said he would replace the entire head unit on the switch. This worked every bit of fifteen minutes, and then it wouldn't work. I went back to the dealership, and when I attempted to show the tech how it didn't work, the damn thing opened and closed perfect. On the way home, it wouldn't work again. There has to be a short somewhere, but until someone can tell me what is going on, its not worth taking a chance.
 
1 - 6 of 6 Posts
Top