Toyota RAV4 Forums banner

1 - 9 of 9 Posts
B

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I did some research in the forums on this topic.. I feel it might need its own thread.. here we go.

History:

-67000 miles
-The engine blew a head gasket at 62000 miles, the dealer fixed the engine under warranty.
-300 miles later, the engine would idle at 600 RPM and it would shudder.. felt as though it was not getting enough fuel.
-Dealer said it was a bad #2 ignition coil and it was replaced.
-Ran fine for 2000 miles..

Now, it's doing it again. Engine starts fine. It will idle around 1000-1200 rpm for a bit.. and then it will idle around 600 and begin to surge. The engine also shakes while it is surging, causing the entire car to shake. The check engine light and VRC Track lights came on about 20 miles into the problem. Has been going on for several days. I drive about 1000 miles a year now.

Could it be ANOTHER bad ignition coil?

Could it be a fuel pump or air intake problem?

Thoughts?

I'd rather not spend another $300 to have the dealer fix the problem, but I'm getting fed up.

Thanks!
 

·
Registered
Joined
·
1,960 Posts
DId you mean 1,000 or 10,000 miles a year?

I vote for a dirty throttle body. Its a common issue.

Easy to clean, just search "throttle body cleaning" in the 4.1 forums and you'll find a how-to, really easy to do
 

·
Registered
Joined
·
1,108 Posts
It could be a lot of things, including something they did wrong, vacuum line on the wrong place, or off, etc.
We cant help much without more info.

You can get the codes pulled for free at some auto parts stores.

Fuel pumps last at least 200,000 miles on the rav it seems.
Any coil failure is unlikely.

What is a vrc trac light??
What year rav?

Brett
 

·
Registered
Joined
·
608 Posts
replace a/f sensor(O2), TPS, TCS, MAP, IAC, wires, plugs, ……..what next?
You are throwing a lot of parts at the problem.
But what is the problem?
 

·
Registered
Joined
·
4 Posts
replace a/f sensor(O2), TPS, TCS, MAP, IAC, wires, plugs, ……..what next?
Car has 160k miles. Plugs, wires, O2 are rountine maintenance. IAC was stuck and no cold high idle so also replaced the TCS. Turns out the MAP was not plugged in all the way in and the new O2 was defective causing surging idle. Now working on fine tuning to see if I can improve gas mileage and power.
 

·
Registered
Joined
·
4 Posts
Car has 160k miles. Plugs, wires, O2 are rountine maintenance. IAC was stuck and no cold high idle so also replaced the TCS. Turns out the MAP was not plugged in all the way in and the new O2 was defective causing surging idle. Now working on fine tuning to see if I can improve gas mileage and power even more. Had no power up hill, replacing MAP improved the power and throttle response.
 

·
Registered
Joined
·
4 Posts
Update. Was able to disassemble OEM IAC and get to the frozen bearings. Once dissassembled, soaked bearings and assembly in fuel injection cleaner. Adjusted cold idle thermo spring to ensure cold high idle. Computer is slow relearning after complete reset but running better. Considering replacing downstream oxygen sensor. Btw beware of counterfeit denso oxygen sensors on eBay....got mine from rock auto.
 

·
Registered
Joined
·
22 Posts
The problem sounds a lot like the one I had with our '96 RAV4 in 2018, but not exactly. We also threw a lot of parts at the problem, and also had a very dirty throttle body.

I just posted an update here...


JC
 
1 - 9 of 9 Posts
Top