Toyota RAV4 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
After several failed attempts, I finally got TechStream working on my Win7 laptop and was able to connect to the vehicle. I have a 2007 and 2009 Rav4, base, 6cyl, 4wd, with wireless key fobs and immobilizer keys.The wizard is recognizing the car as model code GSA, vehicle spec 2GRFE. I've tried all four combinations of options -0812, 4WD or 0812-1112, 4WD with smart key or no smart key. The connection works, but when I select the Immobilizer option, it comes back as not responding or not available. I'm guessing I've got the wrong code/option, but have no idea what to select and the other choices are either 2WD or unspecified.
If it helps, the VIN is JTMBK33V6 75038289
TechStream V. 8.10.021
Cable: Mini VCI J2534 (from generic source)
 

·
Registered
Joined
·
731 Posts
It should show as RAV4, not GSA. When you initially set up TechStream, what country did you choose?

Also, be advised the cheapo Chinese knockoff cable with a clear housing and cable is limited as to what it can actually do. Once you get connected, see if you can view live data or go in Generic. Perhaps the hardware/driver has been updated recently.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #3 (Edited)
It should show as RAV4, not GSA. When you initially set up TechStream, what country did you choose?

.
Almost all of the installation instructions said to pick Europe, so I did. I'll try North America and see if that fixes the problem.

OK, set the region to North America. Now it correctly recognizes the model, the engine, and asks 4WD or 2WD.

<ignore this part from earlier edit>
The main selection menu comes up and I can view all the live data - Engine/ECT, Cruise Control, ABS/VSC/TRAC, etc. The only options that now report as "not supported or not responding" are Immobliser, Theft Deterrent, Accessory Gateway, and Sliding Roof. The last is not surprising since the car doesn't have a sliding roof :) Of course, it's the Immobiliser that I need to access to set up a new key.
<end ignore>

Never mind. All this was so I could add an immobilizer key to my '09. But I was testing the software on my '07, which after many attempts I finally looked at the key - no dot, no immobilizer.
 
1 - 3 of 3 Posts
Top