Toyota RAV4 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I bought a 2006 Rav4 about 6 months/12000km ago. When I bought it(180km on it), it was in rough shape. Running a bit rough, burned blue a bit and had oil light flicker a couple times on the drive home(I got it at a discounted price). After changing the oil and plugs it ran like new, except an occasional knock noise. The noise originally showed up very rarely after a long highway drive. It got worse over time. After a while I got a code I believe it was P1011(OCV for VVTL Open Malfunction), I reset it and it never came back. My first thought was the old oil, when I first bought it the oil was definitely past its life, so I did an oil flush. The flush didn't seem to help. I pulled the OCV to check for sludge and there was none.

Now it has gotten worse, its nearly all the time, the odd thing is I don't see any performance issues only loud knocking. I am going to check out toyota for a price on getting the VVT assembly repaired but I expect it to be very pricy.

I am considering purchasing a replacement motor and with the help of my dad do it myself. This seems excessive though, since other than the noise it runs great! Burns almost no oil and runs very smooth.

Any suggestions would be great!
 

·
Super Moderator
Joined
·
11,461 Posts
Which engine is this? In the USA it would be a 2.4l but overseas it could be a 2.0l.
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,895 Posts
If you are in the US or Canada, Toyota has a special service campaign to repair the 2.4L 4-cyl. engine due to excessive oil burning. If they determine that your engine is burning too much oil, they will repair it free of charge.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Let me clarify,
It burned blue on my drive home with the original oil in it. Once I changed the oil that stopped.
 
1 - 6 of 6 Posts
Top