Toyota RAV4 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter #1
I've written about navigation accuracy issues before and was wondering if anyone else has experienced the following: Tracking will be accurate and then suddenly be blocks or, in one case, miles away from my location. I've recallbrated several times via the "new tires" option in the Navigation set-up menu, not having any luck manually recalibrating.

I had the dealership check it out but of course, it was working as designed and all software was up to date. I'm going to take a video the next time this happens to show them, but once again, was wondering if anyone else has experienced this or had any thoughts on a fix.

Thanks.
 

·
Registered
Joined
·
22 Posts
Sorry, Douglas. I haven't seen this specific problem yet, but I will look for it!

The navigation has been generally accurate for me. I usually run Google Maps simultaneously on my phone to check on the accuracy. There are a surprising number of route differences between the two, and the RAV4 Navigation tends to be conservative with time estimates. However, the differences have never taken me off a cliff or anything and the time difference is just a slight annoyance. All-in-all, I have found a pretty accurate system. Good luck getting to the bottom of this!
 

·
Registered
Joined
·
124 Posts
Discussion Starter #3
Wanted to provide an update on the navigation issue. Fortunately, (I suppose) the navigation acted up on the way to my scheduled 20K service. The Service Advisor observed this and was able to relate to the lead mechanic. They put in another head unit and confirmed mine was faulty...new head unit on order.
 
1 - 3 of 3 Posts
Top