Toyota RAV4 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Diagnosing challenge !!
2008 Sport horn doesn't work.... fuse is fine.. what could cause this... Do remember leaning on the "panic button" on the remote, the horn went off and after turning off the panic alarm, the horn doesn't work at all and when I hit the panic button the lights don't flash...

Could this be a relay issue? Is so where is it located...

Thanks in advance
 

·
Your Humble Administrator
Joined
·
16,418 Posts
The horn relay is in a module in the fuse box near the battery. The module has 4 relays in it--in the photo where you see EFI MAIN, the red 10A fuse just below it is for the horn and the relay is integrated into that module.

145094
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
underneath, suspected... looked at the Chilton Manual.. Wonder how much toyota wants for this.. So with this relay being out, this will impact the Panic alarm lights from flashing ?
 

·
Registered
Joined
·
2,478 Posts
underneath, suspected... looked at the Chilton Manual.. Wonder how much toyota wants for this.. So with this relay being out, this will impact the Panic alarm lights from flashing ?
It cost around $115 for this part. You can get it used cheaper. Ebay has it for $13 plus $4 shipping.

You need to make sure it is the integration relay otherwise you wasted your money but I would first test the horn if it is really working.
 

·
Your Humble Administrator
Joined
·
16,418 Posts
The "clock spring" or what Toyota calls the "Spiral Cable" would not affect the horn sounding with the panic button, only the steering wheel button.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #10
thought of that, the lights don't flash when the panic button is pressed... what else could it be? Now leaning towards the relay
 

·
Your Humble Administrator
Joined
·
16,418 Posts
thought of that, the lights don't flash when the panic button is pressed... what else could it be? Now leaning towards the relay
You need to apply 12 volts directly to the horns to make sure they actually work. It could be a simple wiring problem from the relay to the horns. Or maybe they got unplugged somehow. When you press the horn button, can you hear the relay click? You might need to put your ear right up to it while someone else pressed the button.
 
1 - 13 of 13 Posts
About this Discussion
12 Replies
3 Participants
DL175
Toyota RAV4 Forums
Rav 4 World is the internet's largest Toyota Rav4 SUV and EV online forum community. Discuss towing, modifications, and more.
Full Forum Listing
Top