Toyota RAV4 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Ive had both p0138 and p0606 Come and go lately, Usually coming on after sitting for a week or too. Cleared and they seem to go away. Is there something up with the O2 sensor or is it just dieing. Haven't replaced it yet because the guy at the parts store wasn't sure witch O2 sensor it was.

Now to the real issue. I have the ABS , 4WD, BRAKE, and VSC lights on, No code that I can see, Had a buddy with a Toyota scanner check it out and he found a Rear wheel sensor code. We replaced it but The lights are still on with no traction control. I searched a bit haven't found much.

Thanks In advance, Would like to get her done before the snow starts getting deep.
 

·
Registered
Joined
·
115 Posts
I just replaced 2 of my O2 sensore on my 07 V6. When the O2 Sensor was bad the VSC, Engine, and 4WD lights were on in the dash. This is normal as the engine goes into shutdown mode and tries to be sure all power goes to the engine. Once the O2 sensors were replaced, all lights went out.
 

·
Super Moderator
Joined
·
10,218 Posts
One trick that may revive the O2 sensor(s) is driving in a low gear to rev the engine and heat them up real good. Them "cooling off" may explain why it happens after being parked.

On the ABS/wheel sensor code, did you reset it or them and which one(s) come back?
 

·
Premium Member
Joined
·
1,427 Posts
A CEL for any reason will also trigger the VSC light.
A wheel sensor would trigger the ABS, 4wd, and likely VSC lights

Brake is either a stuck parking brake switch, or low fluid.
 
1 - 4 of 4 Posts
Top