Toyota RAV4 Forums banner

1 - 4 of 4 Posts
K

·
Guest
Joined
·
0 Posts
Discussion Starter #1
The linkage to the obdII was broken and the monitors reset. After about 2,000 miles, they had reset but then the battery died and they reset again. I need to get my car inspected and the evap, o2, catalyst and egr monitors aren't complete. The car needs to pass NJ inspection within 2 weeks or come off the road.
Help!

The dealer has no idea what's causing this, but the local machanic who will do the state inspection says that I need to complete specfiic drive cycles. I have a list of drive cycles from Toyota, and I've done one, but it hasn't reset the monitor. We've put another 2,000 miles on the car and I still can't get the monitors to reset.

Does anyone know how precise the drive cycles have to be. It's next to impossible to complet them on the highway.
 
K

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Thank you!!
I have a copy that that I've been trying to follow, but there was a problem with the fax machine that sent it and I couldn't read (and do) some of the test.

Now all I need to do is figure out which test I should do, since there are several for each monitor.

Do you have any idea how to find out which tests to do for my car? example, the EGR has a test for all excep 1FZ-FE engine and one for a 1FZ-FE engine.

I'll be doing this at 2am so I (hopefully) won't get hit doing 50 in a 65.
 
K

·
Guest
Joined
·
0 Posts
Discussion Starter #4
After 2 trips to Toyota where they said all was well and that all monitors were working, I found out that I've had a bad sensor all this time. It was clearly evident if they had just looked for DTCs, since the car has registered having a P0403 since August.

Hopefully, this will solve my problems.
 
1 - 4 of 4 Posts
Top