Toyota RAV4 Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Hi Steve

I've recently had my O2 sensors go on our 2002 GX RAV4

You'll be happy to know the on board diagnostic port is super easy to find !

It's underneath the steering column (UK car) down and to the right.

It's a white socket, looks similar to an old scart socket

Hope that helps mate
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
Hi Steve

I've recently had my O2 sensors go on our 2002 GX RAV4

You'll be happy to know the on board diagnostic port is super easy to find !

It's underneath the steering column (UK car) down and to the right.

It's a white socket, looks similar to an old scart socket

Hope that helps mate
Hi Fasrford
thanks for that m8 much appreciated can now order a bluetooth unit to connect to it

much appreciated pal :)
 

·
Registered
Joined
·
13 Posts
No worries mate, I've just bought an obd2 reader off eBay for the vast sum of £8.90 !

Works a treat :)

I've ran it alongside a mates better reader and it picks up all the codes, although you have to google what they refer too, where as his more expensive one gives you an idea what the codes for.

I'm guessing your O2 sensors will be playing up if your check engine lights come on mate ?

May be able to help again if so :)
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #5 ·
No worries mate, I've just bought an obd2 reader off eBay for the vast sum of £8.90 !

Works a treat :)

I've ran it alongside a mates better reader and it picks up all the codes, although you have to google what they refer too, where as his more expensive one gives you an idea what the codes for.

I'm guessing your O2 sensors will be playing up if your check engine lights come on mate ?




May be able to help again if so :)
hi thanks but at min got no issues :) other than my aircon not working once car gets to running temp :( and maybe a prob with fans as they dont seem to be going at full speed in engine bay but till get some pennies saved cant do anything about those issues but good news is my engine temp stays at half way on gage so must be running ok
 

·
Registered
Joined
·
13 Posts
No worries steve, get a code reader off ebay mate, cheaper than a bag of chips. Itll point u in the right direction then.

Daft question, are you sure it doesnt need the aircon regassing mate ?
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #7 ·
hi yes that's what has been suggested to me hopefully that's all it is fingers crossed :)

i got a reader from ebay should be here soon

need to borrow my partners samsung tab as my iphone apparently has issues with bluetooth with those readers

i just curious why my fans not run at full speed even when turn aircon on because when car is cold aircon works for a bit but fans still don't turn at full speed
 
1 - 7 of 7 Posts
Top