Toyota RAV4 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I have an OBDII reader and get the DCT code P0031 sensor 01/02 with a pending 02/02 code

I pulled the sensor closest to the rear of the car (cat back sensor? rear downstream?)
cleaned it with Air Mass Flow sensor cleaner and replaced but no change

do I have the correct sensor? is 01/02 the furthest rear sensor? where else should I look?

I watched a youtube video showing how to test the wires on it but i have not pulled it completely since I am not sure it is the correct sensor and wanted to try cleaning it first

where are the 4 sensors located? I found one just in front of the rear sensor under the car slightly up from it on the down pipe.
I see one at the front of the motor up high poking through a heat shield and the auto parts store gave me part numbers for a 4th but not sure where it is

any help as to which sensors (locations) I need to look at first, for 01/02 and 02/02, would be greatly appreciated

thanks
Robert
 

·
Registered
Joined
·
11 Posts
Discussion Starter #2
update: went to part source and bought an oxygen sensor for bank 01 sensor 02, $135! but then Toyota wanted $266 plus tax.

installed it just fine but the OBDII reader still says DCT 01/02 and pending 02/02; cleared the codes many times but the code reader says clear FAIL
using a Veepeak VP30 OBDII; my Panlong scan tool seems to be burnt out as the red light only comes on and not the blue light stating it is ready

could it be the scan tools, or could the NTK sensor be bad? I suspect the parts place will not take it back once installed?
 

·
Registered
Joined
·
1,473 Posts
update: went to part source and bought an oxygen sensor for bank 01 sensor 02, $135! but then Toyota wanted $266 plus tax.

installed it just fine but the OBDII reader still says DCT 01/02 and pending 02/02; cleared the codes many times but the code reader says clear FAIL
using a Veepeak VP30 OBDII; my Panlong scan tool seems to be burnt out as the red light only comes on and not the blue light stating it is ready

could it be the scan tools, or could the NTK sensor be bad? I suspect the parts place will not take it back once installed?
V6 IS THE ONLY ONE THAT HAS 4 SENSORS THE I4 DOES NOT!!
I WOULD DOUBLE CHECK THE SENSOR NUMBER WITH THE DENSO SITE TO MAKE SURE YOU GOT THE RIGHT ONE!

Denso is the OEM. Go here to find your part number then search around to find the best price. I got mine from walmart.com shipped to store.

Find My Part | DENSO Auto Parts


Do you have i4 or v6? If you have i4 go under passenger door and follow the pipe forward to find b1 s2 . Its near the front wheel or axle



If its V6 bank 1 sensor 2 this might help.

 
1 - 3 of 3 Posts
Top