Toyota RAV4 Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all,
This would be a sum-up of 4 days and nights of research of my AF sensors faulty codes. 2001 RAV4, 213K kms, going very strong still. Rebuilt ECU 3 weeks ago and engine light with these codes being on before rebuilding ECU. Came off after rebuilding, then after the first engine turnoff/turnon it came back on (when the ECU re-checked the sensors, I think).

I located the replacement parts, amazon and ebay, and the question is to whoever replaced the AF sensors with generic ones and not Toyota/Denso : did you notice any faults after? Since the originals lasted 200K, if I can get another 70-100K kms off of generic ones, I am happy.

Should I stick to the engraved ones? The 234-9023 and 234-9028 are engraved "Denso" or "Toyota/Denso" on them. The generic ones have no engravings.

The price difference is significant (at least half price).
I understand you get what you pay for, and we should install OEMs as much as possible. Since I am looking to trade up in 6 months, my question arises pertinently, I think.
The bottom line: how bad is the generic? (we all know how good the brand ones are).

Much appreciated and thanks in advance for replies.

PS. The question goes for O2 sensors at the cat as well, I guess.

Cheers,
torontezu
 

·
Registered
Joined
·
5 Posts
Hi, I have the same error codes. Ive replaced bank2 sensor 1 with a cheap Chinese one (£20 on eBay) reset codes and both came back on. So either it's another problem or that sensor is no good. I did check the diagnostics and they are all reading (pics attached) so might be something else. I've checked the fuses and relay, they are all fine. I've attached pics of the fuel trim also. % are only there for cylinders 3 and 4?
Can any dicipher this data and point me in the right direction?

Many thanks,

G
 

Attachments

1 - 2 of 2 Posts
Top