Toyota RAV4 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
we have a 97 rav 4dr,4wd, had it for 5 yrs now. all of a sudden the electric door lock on the drivers door no longer functions on electricity. you can unlock &lock it manually, but the key FOB doesn't work on this door, or by hitting the "lock/unlock" button on the driver's door. all the other doors lock & unlock either by hitting the key FOB thingy or the button on the drivers's door. I removed the door panel and looked inside, everything is there and intact and hooked up, no loose rods, all plastic rod retainers in place. I cleaned the electrical contacts and still nothing. anyone with experience on this, please respond. not much room inside the door or I would explore a little more, meaning disassembly, but working inside a door is not my favorite thing, as I have done this on my vette, a suburban, and an 88 corolla in the past. scratched and bleeding arms, frayed temper and astonished neighbors who did not know there where so many cuss words is the usual result. TIA
 

·
Registered
Joined
·
97 Posts
My quess would be near the alarm system itself is attached to the power locks, that or the actuator that moves the lock is bad. Sorry just to many variables to go wrong to pin it on a discription. Get a voltmeter and see if the actuator has voltage when you try and unlock it, if so it's bad, if not problem lies elsewhere.
 

·
Registered
Joined
·
685 Posts
Have to agree with Brian, ya gotta get in there with a voltmeter and see if it gets a pulse when activated. I'm inclined to think the fault is somewhere in the door not elsewhere. With a '97 the driver's door has been open & closed a lot of times, some thing may have shaken loose or even corroded which would limit the current necessary to active it.
Another thought is the wiring harness between the door and door frame, it's flexed a lot of times. But I think this would affect the other doors...... A quick check of this, may be to hold the switch to lock/unlock and just flex the harness a bit and listen for the solenoid to work.....
It has to be something in common with the door switch and remote FOB as neither works it.............solenoid itself???
Good luck!
 
1 - 4 of 4 Posts
Top