Toyota RAV4 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
It appears I have a bad contact on my map/dome light assembly. The drivers side does not work, but the passenger side is fine. The bulb is not blown so I assume its a bad contact. I switched the bulbs just to make sure.

Has anyone ever removed this? There are two screws under the lens. I assume if I move them the whole assembly will come out, but before I break something I thought I would see if anyone here ever took one out and if there are any additional clips?

Thanks in advance
 

·
Registered
Joined
·
10 Posts
Removing Map Light Assembly

I don't know when you posted this. I am returning to this site after many months. My map light on the driver's side does not work either. The passenger side works fine. I have a 1996 RAV4. One of my little projects is to fix this lamp. Lots of little problems like this in our RAV4. My first thought is that it should be simple. Maybe take out the whole lamp assembly and make sure all the wires are connected, then simply putting it back in.
I hope yours works out well for you.
Oh, and it is April 28, 2016 now.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
I removed and replaced the assembly with one I found on ebay. It was very simple and the new one worked just fine for a few days, then i began having the same problem on the other side. It occurred to me that perhaps the contacts were just dirty. I sanded them lightly and all is working fine now. I should have tried that first because I’m now thinking I replaced the whole assembly for nothing. Luckily I got it for once $25 bed on ebay. Before you replace yours try sanding the contacts...and thanks for the reply!
 
1 - 3 of 3 Posts
Top