Toyota RAV4 Forums banner

1 - 20 of 25 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I just bought a 2009 rav4 for my wife. The radio will not power on at all. All 3 power outlets, the clock and the switch for the mirrors does not work either. I have checked all fuses and even pulled the radio out to make sure the wiring was connected correctly.We just moved from az to fl so I can't bring it back to the dealer and have them check it! Can someone give me some advice on what to check next?
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,639 Posts
Did you check ALL THREE fuse boxes? There is one under the dash behind the hood release lever, and two under the hood--one on the driver's side near the battery and the other on the passenger side.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Yes, I checked all three fuse boxes. The fuses are fine but no power is going to it. I tried swapping the #5 relay's also and when I turned the key to acc, i didn't hear clicking. This is all new to me, I've worked on Fords with no problem but I can't seem to get this!
 

·
Registered
Joined
·
1,912 Posts
I just bought a 2009 rav4 for my wife. The radio will not power on at all. All 3 power outlets, the clock and the switch for the mirrors does not work either.
It would be more helpful to diagnose the problem if I knew which trim level your RAV was, and what options it had. For example a Limited with automatic HVAC has a different clock circuit than the other models. The wiring for JBL and non-JBL radios is also different.

At this point, all the problems you described ( except for the cigarette socket below the radio) can be explained by a blown 7.5 ACC fuse.

This fuse is located on the panel by the drivers left knee. It will be brown in color. You can see it in the bottom row of this image.


If this fuse was indeed blown, you would also have trouble with the following devices. Can you confirm if any of these other devices have stopped working?

Audio System (Except JBL)
Audio System (JBL)
Automatic Air Conditioning and
Clock (w/ Automatic Air Conditioning)
Clock (w/o Automatic Air Conditioning)
Door Lock Control
Headlight
Interior Light
Key Reminder
Light Auto Turn Off System
Power Outlet (12V)
Remote Control Mirror
Shift Lock
Wireless Door Lock Control
 

·
Super Moderator
Joined
·
9,983 Posts
I'd use a 12V test light to check for power at both sides of each fuse. Only way to be sure and trace this down, IMO.
 

·
Registered
Joined
·
3,627 Posts
You can also swap those 3 fuses out also just to rule out it is indeed ok. There are 3 spare fuses 7.5 amp, 15 amp and another one can't remember in the fuse box located on the engine passenger side to use as a test fuse.
 

·
Super Moderator
Joined
·
9,983 Posts
The test light allows not only checking the if the fuse is good but if it's getting power. If not then you check further at relays etc.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Sure, it's a RAV4 base 4 cylinder 2wd. It's not a JBL radio either. I checked the brown fuse, it was fine but I replaced it just to make sure and nothing has changed. The audio (no JBL), clock (w/o automatic a/c), 12v power outlet(s) and remote control mirror switch is still not working either. The test light lit up strong when I tested those particular fuses. i just went and bought a digital multimeter so I can check the relays but I have never done that before. My wife said she didn't try the radio since she was traveling with our kids and they had their tablets so she isn't sure if it even worked when she picked it up or if something happened while driving. Could something just be wrong with the radio and that's what causing all of the other problems?
 

·
Registered
Joined
·
1 Posts
I have the same problem. Fuses are all fine. The only thing I can think of is corrosion in a junction box or inline fuse due to an aftermarket windshield, but I have no idea where that may be. Did you get your's working and how?
 

·
Registered
Joined
·
14 Posts
I just recently had a weird issue in mine where the radio would shut off when I turned on the headlights. Turned out that the 10A fuse in "GAUGE1" had blown when I was installing my rear view camera.
 

·
Super Moderator
Joined
·
9,983 Posts
I just recently had a weird issue in mine where the radio would shut off when I turned on the headlights. Turned out that the 10A fuse in "GAUGE1" had blown when I was installing my rear view camera.
Makes sense since that fuse also powers the backup lights where I'm sure you tapped in to turn on & power the camera.
 

·
Registered
Joined
·
9 Posts
Hi there. Did the issue with the radio not powering on got solved? I have the same problem with mine after a battery replacement.
 

·
Registered
Joined
·
4 Posts
I have almost the same issue. 2011 4wd, 4 cyl. Radio, clock, power mirrors, and all 3 power outlets not working.
Checked all fuses under dash and both compartments under hood-all are good.
Checked for short with milliamp tester at battery-good also.
Removed access panels around steering wheel and near under-dash fuse panel, looking for hidden fuses that may have blown-nothing.
Loosened and tightened ground connections-nothing changed.
I have battery voltage coming from the small red wire at the ignition switch when the key is at Acc.or On.
There is 0 voltage at the gray wire that should supply 12v when the key is at Acc. or On.

Anyone have experience that yielded positive results?
 

·
Registered
Joined
·
2 Posts
I have almost the same issue. 2011 4wd, 4 cyl. Radio, clock, power mirrors, and all 3 power outlets not working.
Checked all fuses under dash and both compartments under hood-all are good.
Checked for short with milliamp tester at battery-good also.
Removed access panels around steering wheel and near under-dash fuse panel, looking for hidden fuses that may have blown-nothing.
Loosened and tightened ground connections-nothing changed.
I have battery voltage coming from the small red wire at the ignition switch when the key is at Acc.or On.
There is 0 voltage at the gray wire that should supply 12v when the key is at Acc. or On.

Anyone have experience that yielded positive results?
 

·
Registered
Joined
·
8,423 Posts
Also suggest checking fuses with a continuity tester as a fuse may blow without it being visually apparent.
 

·
Registered
Joined
·
9 Posts
All fuses are fine and they test good ... found some rust in a relay plug juste beside the fuse box but not sure what it is for ...?
 

·
Registered
Joined
·
3,627 Posts
If you have an aftermarket radio there is a fuse at the back of the radio. One member had a faulty usb charger blowing fuses and one of them was the radio fuse.
 
1 - 20 of 25 Posts
Top