Toyota RAV4 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi everybody , i have a Toyota rav4 2007 when i press the accelerator pedal it dont work car running very slow . after few hours when i press back accelerator pedal work normally .
it's already happen 3 time in one month .

do you have any idea about this issue
 

·
Registered
Joined
·
22 Posts
My rav4 just had kinda similar problem. It lost power and wouldn't get over 20 mph so I changed the coil packs and spark plugs. It helped a little bit for a few minutes but then went back to the same only going 20 mph. I noticed that it when I pressed the accelerator that it done differently. Well it ended up being my catylic convertor stopped up. It was the first cat, mine has two and my problem is fixed. Might not be what's wrong with yours but wouldn't hurt to look into it

Sent from my SM-G960U1 using Tapatalk
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,513 Posts
If the catalytic converter is truly stopped up, you will see the engine temperature go up on the gauge.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
If the catalytic converter is truly stopped up, you will see the engine temperature go up on the gauge.
Thank for your response JuneBug, i only see engine alert light . my problem why after some hours it working fine.?


146299
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
My rav4 just had kinda similar problem. It lost power and wouldn't get over 20 mph so I changed the coil packs and spark plugs. It helped a little bit for a few minutes but then went back to the same only going 20 mph. I noticed that it when I pressed the accelerator that it done differently. Well it ended up being my catylic convertor stopped up. It was the first cat, mine has two and my problem is fixed. Might not be what's wrong with yours but wouldn't hurt to look into it

Sent from my SM-G960U1 using Tapatalk
Hi Marieg25 . did the coil packs and spark plugs fix your problem . ?
if not which change fix your problem ?:)
 

·
Registered
Joined
·
3,138 Posts
Herdj, you have four lights lit: engine check, TRAC OFF, 4WD and another green bulb light. Unless you have a code reader and know how to fix cars I recommend you take your car to a mechanic. These types of problem can get complicated and difficult to diagnose. Another thing is that your car is not safe to drive and should be fixed asap.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #9
Herdj, you have four lights lit: engine check, TRAC OFF, 4WD and another green bulb light. Unless you have a code reader and know how to fix cars I recommend you take your car to a mechanic. These types of problem can get complicated and difficult to diagnose. Another thing is that your car is not safe to drive and should be fixed asap.
Thank you DL175 i think so.I will take it to a mechanic . thanks a lot for your recommendation
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10 (Edited)
Dear all thank your for your Help . i would like share with you what solve my Accelerator problem .I remove the following censor clean it,then put it back.my accelerator work perfectly till now
147662

Video Link :
 
1 - 12 of 12 Posts
Top