Toyota RAV4 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hi All, I have a 2001 Rav4 with 150K miles. Recently out of nowhere, without any other problem, the transmission started slipping between 1st and 2nd. At first I got no error codes on a diagnostic, but had a full transmission service done, and it ran great for about a week. Then, the same problem returned.

My mechanic diagnosed again and got a solenoid B error code (I assume P0755), so I looked into replacing the whole solenoid system at a price of $1200.

My ECM was reflashed (not replaced) in '08.

Question is, is the real problem the ECM or the solenoids?

If I fix one, do I have to fix the other?
 

·
Registered
Joined
·
47 Posts
assuming you haven't replaced the ECM already, it would be good preventative maintenance to replace it now. If the exact error's still pop up after clearing, then you can look at replacing the system. But at that point, you know your ECM should be good to go too.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
assuming you haven't replaced the ECM already, it would be good preventative maintenance to replace it now. If the exact error's still pop up after clearing, then you can look at replacing the system. But at that point, you know your ECM should be good to go too.
So could the ECM possibly be sending bad instructions to the solenoid?

Is this something I can fix myself or does the dealership have to program the ECM? Thanks.
 
1 - 4 of 4 Posts
Top