Toyota RAV4 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
When removing the rear differential in my 2008 limited v6 4x4, I pulled out one of the wires from the male end of the electrical connector that comes from the wiring harness. I shoved it back in and shrink wrapped it, but I now get a 4x4 warning light on the dash after reinstalling everything... I did have a VSC, CEL too, but they went away after disconnecting the negative cable from the battery for a while. I'm thinking the connector needs to be fixed and wondering the best way to do so. Would buying the oem wiring harness part #8216442010 be my best bet and how could I confirm the connector I need is actually included in that wiring harness? Or is there a way to acquire individual connectors to solder on to the wires?
 

·
Registered
Joined
·
53 Posts
I think you are correct in that pulling the wire is causing your problem, depending of course on what you did to your differential. In any event the wiring harness to which you referred is available on line at #8216442010: Toyota. WIRE, FRAME. WIRE, FRAME

Assuming this is the correct one you may be able to just splice in the to your existing harness using only part of the new one.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I replaced the axle seals and cleaned up the breather vent. Could something have happened while reinstalling the axles?

Have you ever repaired an electrical connector where the wire was pulled out? Seems like it might be doable if I could figure out how to disassemble the connector.
 
1 - 3 of 3 Posts
Top