Toyota RAV4 Forums banner

1 - 20 of 106 Posts

·
Registered
Joined
·
285 Posts
Discussion Starter #1
I replaced the backup and turn signal lights with LED'S. Don't know why they are not working. The rear signal lights work.
 

·
Registered
🇨🇦 2020 RAV4 XLE Hybrid - Super White
Joined
·
500 Posts
The obvious solution could be, did you plug the connector for the tail light back?

When I installed my LED's to tap resistors in, I removed both (x2) connectors attached to the light housing so I could have more room instead of it dangling by one cable.
 

·
Registered
Joined
·
285 Posts
Discussion Starter #12
No I removed all led's and turned them `180 Degrees. Then I pulled out all fuses and all were good.
I don't know what else to do.
 

·
Registered
🇨🇦 2020 RAV4 XLE Hybrid - Super White
Joined
·
500 Posts
So based on what you're saying, and this how I'm reading it to help try working backwards:

-removed tail light assembly
-removed tail light AND turn signal connectors
-removed brake light diode (which already is LED) and replaced it with an aftermarket LED diode *misread your post, you meant rear backup lights 🍻
-removed halogen signal bulb and replaced it with an aftermarket LED diode w/ built-in resistor (from your other posts)
-connected both connectors back once BOTH bulbs were installed in their correct socket
-tail light housing was fit back correctly

-What other user mean by reversed polarity is flipping the bulb/diode 180 degrees, not spinning the bulb with it's socket to make it secure:

-You lost me at the fuses... did you remove any fuses from under the hood or under the steering column? If so, that's an obvious no no

-The 3rd problem could be again, a loose connection, meaning you didn't clip it in fully, from my experience it took some strength to get it back in. Revisit your work and make sure the quality is there, errors sometimes happen to the best of us

-4th, you installed a bulb that doesn't work with your car, the brake light is already LED so it baffles me you replaced the OEM LED brake light with an aftermarket LED. Unless you did that mod with the harness that makes the brake light illuminate as DRL
*misread your post, you meant rear backup lights 🍻


This is how I would approach the problem, if this doesn't help maybe go to your dealer so they can help before you damage something sensitive. Electrical stuff is pricey to fix especially damaged wire harnesses, know your DIY limits 🤘
 

·
Registered
Joined
·
1,936 Posts
For trouble shooting you need to put the bulb back in. Pick one side. Then replace the bulb with the original incandescent bulb. See if it works. Then report back. You are making tons of changes at once making it difficult to pinpoint the problem.
 

·
Registered
Joined
·
1,412 Posts
Yeah, it's difficult to understand what's the issue, title says one thing, but first sentence is another thing. Ok, just to confirm you replaced LEDs in your turn signals front and back and the backup lights. Your LED turn signals are working, but your backup LED lights are not. If you already tried them switching 180 degree, the other issue I believe I also had with replacing backup lights is that light did not fit properly in the socket and/or didn't reach the contacts. So that might also be the case for the backup lights.
 

·
Registered
Joined
·
166 Posts
No I removed all led's and turned them `180 Degrees. Then I pulled out all fuses and all were good.
I don't know what else to do.
I think you have a blown fuse. You will have to find it. did you check the fuse in the engine compartment. There are two fuse boxes.
 

·
Registered
Joined
·
285 Posts
Discussion Starter #17
First.I was told to check the fuses.
They were all good. Led backup lights work.I added led rear signal lights they work.Front side marker led's.Thats it for the outside.
 

·
Registered
Joined
·
1,412 Posts
First.I was told to check the fuses.
They were all good. Led backup lights work.I added led rear signal lights they work.Front side marker led's.Thats it for the outside.
Lol I am confused what doesn't work?
 

·
Registered
Joined
·
285 Posts
Discussion Starter #19
No light's in the rear of the car at nite only the backup and rear signal lites work.
I can not drive at nite.
 

·
Registered
Joined
·
285 Posts
Discussion Starter #20
Yeah, it's difficult to understand what's the issue, title says one thing, but first sentence is another thing. Ok, just to confirm you replaced LEDs in your turn signals front and back and the backup lights. Your LED turn signals are working, but your backup LED lights are not. If you already tried them switching 180 degree, the other issue I believe I also had with replacing backup lights is that light did not fit properly in the socket and/or didn't reach the contacts. So that might also be the case for the backup lights.
No lights in the rear of the car at nite only the backup and rear signal lites work.
I can not drive at nite.
 
1 - 20 of 106 Posts
Top