Toyota RAV4 Forums banner
1 - 6 of 14 Posts

Registered
Rav4 1997 Automatic 4WD - White
Joined
154 Posts
Discussion Starter · #1 ·
Hi Everyone,

Recently I replaced the injectors for brand new ones, also, replaced the adapters for the same. Valve cover seal and gourmets. Replaced the fuel filter, and both Oxygen sensors of bank 1. I'm super happy for the economy in fuel and power these replacements resulted.. for sure it's made my Rav feel better and run like it should.

One problem though,, I'm still getting the vibrations.. On gear (D/1/2/R) and full stop. I wonder if these hoses in the pictures attached are supposed to flow air.. I replaced the hose that goes from the middle of the injectors below the valve cover, to the IAC valve.. I blew on it, but seem no air was going through. I wonder if this is clogged and it's causing the engine to bad iddle.. vibration.. 650 -690 rpm.

Also, on the image attached I wonder if this also supposed to have air flowing.. or vacum I blew on it and no air passage. I wonder if any of you know where these hoses supposed to go.. and confirm if there's no air through,, I should unclog with a snake or wire.

Here is an image with arrows where I need to know if there should be air through.. which explains why it shakes.. air is not being sucked by the IAC therefore engine shakes..
 

Attachments

Registered
Rav4 1997 Automatic 4WD - White
Joined
154 Posts
Discussion Starter · #4 ·
OP: Also search on here for testing the EGR system, including a good video on such. If your models are the same, there is a solenoid valve on the back of the 3S-FE that often needs replacing (and relocating to the firewall). A royal PITA, that valve is to get to. And only use a Aisin replacement.
Hi LugNut, did that already.. still getting p0441 馃槬 I don't know what else to do for that issue. however wondering if identifying where those hoses supposed it ma also fix the code error..
 

Registered
Rav4 1997 Automatic 4WD - White
Joined
154 Posts
Discussion Starter · #5 ·
is that for the PCV hose ?


Hi crisps, I don't know.. PCV goes on top of the valve cover..this is below the valve cover.. and between injector 2 and 3
 

Registered
Rav4 1997 Automatic 4WD - White
Joined
154 Posts
Discussion Starter · #9 ·
our ravs are getting old now.
if you have not done the hoses and the rest of the rubber now is the time for sure.
8-10 years max on the rubber stuff.
hidden cracking causes lots of issues.
a mityvac test kit is handy to find these leaks
Hi iowagold, Thank you for your input. I do have that,, but may not know how I can test the lines, I will have to search for proper pressures on every hose connection.

I was wondering getting a EVAP smoke machine leak detector. Do you know of a good brand?

I saw this one: https://www.amazon.com/dp/B09QM4PR5...&pd_rd_r=0c090aec-94ec-4850-843c-3b9c4b159b1c

Do you know if it's worth it?

Cheers!
 

Registered
Rav4 1997 Automatic 4WD - White
Joined
154 Posts
Discussion Starter · #11 ·
if you pay 20 bucks you can go to techinfo.toyota.com and get all the
troubleshooting and diagnostics and specs and what hose goes where....for all of that.
Thank you for the option.

By the way here is the sencond hose.. pointed by red arrows. Perhaps someone has been that path?
 

Attachments

1 - 6 of 14 Posts
Top