Toyota RAV4 Forums banner

1 - 20 of 37 Posts
R

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I've been reading the forums and I haven't found someone else with the same problem so I decided to start a thread.

When I turn on the car it shoots out a cloud of smoke out the exhaust. The "check engine" light is on and I had it diagnosed at Pepboys and they said I needed two new oxy sensors. I haven't changed them because I don't think that's the problem. I am confused with what could be the problem. I am thinking that the problem could be a leaking injector because the engine doesn't smoke once its running.
 

·
Registered
Joined
·
471 Posts
if the smoke is blue I think there might be something wrong with engine oil.
 

·
Registered
Joined
·
31 Posts
From my experience in 2 other cars (Fords... I know, never again) it sounds like valve seals. If you don't know what that is, here's a simplistic explanation. The stem of each valve has a rubber (or something like it) seal around it. As the valve goes up and down it passes through these seals. If the hole in the seal is enlarged, more oil can pass thru. When the car sits for a while (like several hours) the oil collects around the seal and leaks into the combustion chamber. When you start the engine, PUFF, that excess gets burned off and you see it behind you.
Since I'm not a mechanic, I can't tell you why the oil doesn't get forced thru that seal constantly, under pressure. But the "disease" produces the symptoms you stated.
The good side is that you can still pass Inspection 'cause it only happens at startup and you're not really burning oil constantly.
Jim.
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #7
I had the same problem with my 96 RAV4.

VALVE SEALS :!:
 

·
Registered
Joined
·
682 Posts
Yup, blue smoke means oil is involved and almost always is valve seal problem. My 96 RAV4 has this problem too...occasional blue puff of smoke on start up. I keep an eye on oil level and usually have to add some between services (every 10,000 km). But i havent heard of this problem occuring on a 4.2 till now.
 

·
Premium Member
Joined
·
3,348 Posts
Mohit said:
Yup, blue smoke means oil is involved and almost always is valve seal problem.
My '96 has had this same puff of blue smoke on a COLD start for the past 50,000+ miles. I do keep an eye on my oil level. I've never had to add any oil... between my usual 5000 mile oil changes :D
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #10
Thanks for the info. I will see where I can get it fixed. Can larger valves be installed for more power or will it interfere with the variable-valve-timing.
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #11
I'm no help on the larger valves but I'm wondering how many miles you have on your RAV4
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #14
I am having the same problem with my 2001 RAV4. The check engine light was on so I took it to the mechanic. Black smoke has been coming out the back at start-up for the last 6 months or so. The mechanic said I need a new oxygen sensor. When they got the part they tested it again and now they say I need a new catalytic converter. I will be getting another opinion this week. The car now has just over 100,000 miles.

The second opinion agreed with the first. I now have a new converter and no further problems with my car, the problem has transfered to my checking account. Ouch!
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #15
short block being replaced

My 2001 RAV4 Auto has about 97,000km (luckily still under warranty). I don't drive the RAV4 hard, all maintenance is done as per schedule, and still on my original set of bridgestone tires!

I started getting puffs of smoke at startup only occasionally a couple months back, but has started to happen everytime the car has been sitting 4-5 hours. At first, the dealership diagnosed it as worn valve seals, I called them back a couple days afterwards to see when i can pick up my car, they found that it has damage to the piston rings and some other components as well. They will be replacing the whole short block, all under warranty. Dunno if this is a good thing or not.. :?

Fellow RAV4'ers who are still under warranty should carefully check and see if the car shoots a puff of smoke at startup as it maybe something more.
 

·
Registered
Joined
·
65 Posts
We have an 03' that started puffing blue smoke at startup around 85K miles. It has gotten progressively worse to the point we have decided to trade it for a new RAV before it dies.
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #17
Bought my 2001 new and in 2006 I noticed blue smoke coming out when I first started the engine. Once it warmed it stopped. Took it to Toyota and they replaced the valve seals. Sorry to say not a cheap fix but that cured the problem.
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #18
Oil burning at start up cured

I purchased a 99 Rav4 about 5500km ago. It had 84K km on it. It smoked at start up every time and was noisy running for a toyota. I have a 79 Corona with 300K km on it and it smoked at start up and used oil once you hit 5K km on an oil change. It no longer uses oil or smokes. I change my oil every 5K km. Sometimes it goes over before I get a chance to do it. My Rav4 no longer smokes and the engine is very quiet, it only took 5K km.

Anyway I thought all you out there would like to know how I stop these vehicles from burning oil without any mechanical intervention.

At every oil change I add one bottle of Rislone ENGINE treatment CONCENTRATE. Just follow the directions on the bottle. I also add 25ml of automatic transmission fluid at every gas fill up. You can add 50ml every second or third etc. Don't go over 50ml or it will carbon up your pistons and it will diesel when shut off.

An old mechanic told me the trick about the transmission fluid 25 years ago and I have always used it to help keep the fuel lines clean and lubricate the upper cylinders.

I have read that the Ravs4s are famous for this and everyone's remedy was to change the valve seals. I thought this would work and it did. It may work for you. It cannot hurt anything and will save you money in the long run and sooner if it fixes the smoking at start up.

If it works for you let everyone know.

Happy Raving!
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #19
I have a 2002 RAV4 with 95000 miles on it. It was purchased Toyota certified used at 57000 miles. Every startup in the morning there is a white puff of smoke coming out the exhaust. I haven't noticed a blue puff. Would this be similar to the valve seal issue that other RAV4 owners are experiencing?
 

·
Registered
Joined
·
22 Posts
joepat2001 said:
Bought my 2001 new and in 2006 I noticed blue smoke coming out when I first started the engine. Once it warmed it stopped. Took it to Toyota and they replaced the valve seals. Sorry to say not a cheap fix but that cured the problem.
The seals cost about $45. This seal replacement will eliminate "blue" smoking at startup. This is a one day job in your garage if your are handy. Here is a link that is pretty good and a process that works on the Rav4 too (same valve/seal setup). http://www.lextreme.com/valve_seals.html
 
1 - 20 of 37 Posts
Top