Toyota RAV4 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter #1
This week, I've had terrible luck with my 1997 rav. Part of my exhaust pipe split, so my car sounds like it's been straight piped, my headlight went out, and now my speedometer and odometer won't work. I opened up the instrument gauge, and unplugged and plugged the plastic wire connector back in, still to no avail. My mechanic told me over the phone it might be a transmission problem, but I wanna know if it could be anything else before I throw $100 at an easy fix. I don't wanna keep driving if I will be losing track of mileage. Ugh, let's hope nothing else goes wrong, and thanks for the help guys.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
731 Posts
Does the MIL come on and then go out when the engine starts? Are there any fault codes stored in the PCM? Does the transmission shift ok?

If there are no fault codes stored and the transmission shifts ok, then the problem is most likely in the speedometer head.

Does the RAV have cruise control? If the cruise control works, the speed sensor in the transmission has to be working correctly. This would be a speedometer problem.
 

·
Registered
Joined
·
105 Posts
Discussion Starter #3
My MIL light comes on and stays on, I'm not sure how to check for fault codes in the PCM, and also not sure what shifting "ok" is. If it's in regards to the gear shifter, it seems fine to me. I do have cruise control on my car. Sorry, I'm not super savvy with car stuff. Thanks so much for your help. :)


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
609 Posts
When my MIL light came on I stopped by Autozone, they hooked a box up under the dash and gave me a printout of the codes for free. Looked the codes up in the Toyota manual and it said I had a loose gas cap, tightened the cap and the light has stayed off.

Shifting ok means normal and not any big changes in how the car shifts.

If you can activate the cruise control and have it hold a speed then the sensor in the transmission is working and your problem is elsewhere.

Look around where the exhaust split and see if the hot exhaust cooked any wires near the transmission.

Have fun.

My MIL light comes on and stays on, I'm not sure how to check for fault codes in the PCM, and also not sure what shifting "ok" is. If it's in regards to the gear shifter, it seems fine to me. I do have cruise control on my car. Sorry, I'm not super savvy with car stuff. Thanks so much for your help. :)


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: jafladd

·
Registered
Joined
·
105 Posts
Discussion Starter #6
Well, my odometer and speedometer don't read, and my cruise control has stopped working. So I'm assuming it's the speed sensor, which costs about $16 at carparts.com. Just trying to figure out how to replace it. Any ideas?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
609 Posts
These are from my 99 manuals so there may be a small difference.
The loca.pdf show the location and the insp.pdf covers how to test the sensor.

Looks easy.
 

Attachments

·
Registered
Joined
·
1 Posts
try to change the 4.00MHz oscillator ceramic chip inside the speedometer gauge. similar one available from Digikey for a mere $0.70. (404 | DigiKey detail/en/ZTT-4.00MG/X902-ND/82182). Toyota Camry Questions - 1999 Camry Speedometer/Odometer not working, transmission slipping - CarGurus
https://www.youtube.com/watch?v=4uYo1dfH...
This video explains the 3 simultaneous symptoms others have had and shows the process of how it’s fixed. Hope this helps everyone who may run into this issue.
3 issues are:
1. speedometer not moving
2. odometer digital display is blank
3. shifting is erratic while trying to accelerate
 
1 - 9 of 9 Posts
Top