Toyota RAV4 Forums banner

1 - 20 of 38 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I am about to look into a starting problem on a 2006 Rav4. It seems that after the car is hot it will not start. However, when it cools down it will restart and run just fine.

This issue began after the recall was done to the engine for excessive oil consumption. They apparently installed new rings (engine rebuild). After this was done, the car failed to start 3 times. Two times Toyota looked at the car and said they could not find a problem. The 3rd time they checked it out, they said it was the fuel pump. I am wondering if this was a guess! I question the fuel pump being an issue because it runs fine when cold and will continue to run fine hot until that one time it is turned off (when filling the gas or stopping for a few minutes) but not every time. However, it did hesitate one time on a right turn.

I have heard that this has been an issue on a few Rav4s after the recall for the oil consumption recall and I am looking for a little input.

Is this an issue with the

Fuel pump
Crank position sensor
Other

Gus
 

·
Super Moderator
Joined
·
9,546 Posts
What exactly happens when it fails to start?
No noise, clicking, cranking normally w/o start, cranks slowly?
 

·
Registered
Joined
·
237 Posts
Yeah, what he said?

If the engine doesn't "turn over" when hot, I'm guessing the starter is starting to fail. It will have a hard time turning over a hot engine versus a cold one because of more compression when the engine is hot. Since your engine was rebuilt, that could be the case.
I have also experienced this before if the timing is too far advanced, the starter will struggle to turn over a hot engine. This was always the case with the older cars, not positive on the newer fuel injected models.
 

·
Registered
Joined
·
8,184 Posts
When Toyota said that the problem is the fuel pump, did they actually test the fuel delivery pressure? If so, did they test it with the engine both at operating temperature and cold? That their statement that the fuel pump is the problem is suspect since the pump isn't located anywhere near the engine. If the engine cranks normally when hot it is possible that there is an electrical connection which was not reconnected properly after the engine was rebuilt or that some other electrical component is developing increased resistance at it becomes heated. Has Toyota checked for fault codes with a code tester?
 

·
Registered
Joined
·
13 Posts
The car runs fine you pull into a store for a few minutes come back out and the engine will turn over but will not start. Remember it does not do this all the time. When it does start I does not hesitate it just starts up like nothing happened.

I agree that the pump is questionable. This was not an issue before the engine was rebuilt however, it could be coincidental. I have not done any troubleshooting on it yet but plan to start soon. This is our daughters car and trying to get a handle on a few possibilities.

I have not talked to Toyota myself but plan to ask them a few questions.
 

·
Registered
Joined
·
237 Posts
The car runs fine you pull into a store for a few minutes come back out and the engine will turn over but will not start. Remember it does not do this all the time. When it does start I does not hesitate it just starts up like nothing happened.

I agree that the pump is questionable. This was not an issue before the engine was rebuilt however, it could be coincidental. I have not done any troubleshooting on it yet but plan to start soon. This is our daughters car and trying to get a handle on a few possibilities.

I have not talked to Toyota myself but plan to ask them a few questions.
Bring it back to toyota , it does sound like they messed something up when they worked on it....
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
I agree but they have checked it 2 times and said they did not create this problem.

Gus
 

·
Registered
Joined
·
2 Posts
I am about to look into a starting problem on a 2006 Rav4. It seems that after the car is hot it will not start. However, when it cools down it will restart and run just fine.

This issue began after the recall was done to the engine for excessive oil consumption. They apparently installed new rings (engine rebuild). After this was done, the car failed to start 3 times. Two times Toyota looked at the car and said they could not find a problem. The 3rd time they checked it out, they said it was the fuel pump. I am wondering if this was a guess! I question the fuel pump being an issue because it runs fine when cold and will continue to run fine hot until that one time it is turned off (when filling the gas or stopping for a few minutes) but not every time. However, it did hesitate one time on a right turn.

I have heard that this has been an issue on a few Rav4s after the recall for the oil consumption recall and I am looking for a little input.

Is this an issue with the

Fuel pump
Crank position sensor
Other

Gus
I’m having same problem with my 06 rav4 now any solutions yet
 

·
Super Moderator
Joined
·
9,546 Posts
I’m having same problem with my 06 rav4 now any solutions yet
What exactly are your symptoms? And tell us more about the car. I4 or V6? Miles? How old is the battery?
 

·
Registered
Joined
·
2,438 Posts
Like the doc said, 4 or 6? How old is the battery? If it's more than say 3 yrs old and it's a V6, consider replacing it, or at least have it properly load-tested.
 

·
Registered
Joined
·
237 Posts
Randomly won’t start back up after getting hot spins over strong will not fire after sitting 10 to15 min cranks and runs normal
If it turns over strong, then the battery isn't a problem. Sounds electrical like the pump isn't starting or the injectors aren't firing. You must be getting a code? Have the garage keep it for a few days to try and duplicate what you're seeing. If it wasn't doing that before you had the work done, I would tell them to repair what they messed up!
 

·
Registered
Joined
·
1 Posts
Hi,
Did you find any solution to this issue? I have a RAV4 III and I have the same problem. Sometimes the engine starts just fint, like nothing is wrong. But all the sudden it won't start - it does not even try to crank the engine. The battery is fine, everything else is fine... It's almost like my car sometimes is in a bad mood ;)
 

·
Registered
Joined
·
387 Posts
Fuel pressure regulator, fuel pump/relays, crank/cam sensors? Find soneone with a data stream scanner. Get it warm and shut it off. Then watch the data as you crank it. You'll find it. One thing I would recommend is installing a fuel pressure gauge and watching it while you crank. If it doesn't build pressure instantly, drops off, or reads less than iirc 50 lbs, your pump is bad or your regulator is shot.
 

·
Registered
Joined
·
1 Posts
This is happening to us as well. We have a 2008 RAV4 that works fine first thing in the morning and after its been sitting all day while I'm at work. But if I stop to run an errand on the way home, when I get back in, it won't start. So, its like its only an issue when its hot. When I turn the key, it sounds like its starting but when I let go of the key, it just dies. When I turn the key again to start it, it just makes a grinding noise. At that point, I'm able to start it immediately by having someone jump me. Also, if I wait a bit, I'm able to start it just fine as well, as if its cooled off.
 

·
Registered
Joined
·
237 Posts
This is happening to us as well. We have a 2008 RAV4 that works fine first thing in the morning and after its been sitting all day while I'm at work. But if I stop to run an errand on the way home, when I get back in, it won't start. So, its like its only an issue when its hot. When I turn the key, it sounds like its starting but when I let go of the key, it just dies. When I turn the key again to start it, it just makes a grinding noise. At that point, I'm able to start it immediately by having someone jump me. Also, if I wait a bit, I'm able to start it just fine as well, as if its cooled off.
The starter will act like that when it's on it's last legs. That has been my experience with owning many older cars. They turn the engine over fine when cold though. I would look at the starter especially if it can be started with a boost.
 

·
Registered
Joined
·
15 Posts
I am about to look into a starting problem on a 2006 Rav4. It seems that after the car is hot it will not start. However, when it cools down it will restart and run just fine.

This issue began after the recall was done to the engine for excessive oil consumption. They apparently installed new rings (engine rebuild). After this was done, the car failed to start 3 times. Two times Toyota looked at the car and said they could not find a problem. The 3rd time they checked it out, they said it was the fuel pump. I am wondering if this was a guess! I question the fuel pump being an issue because it runs fine when cold and will continue to run fine hot until that one time it is turned off (when filling the gas or stopping for a few minutes) but not every time. However, it did hesitate one time on a right turn.

I have heard that this has been an issue on a few Rav4s after the recall for the oil consumption recall and I am looking for a little input.

Is this an issue with the

Fuel pump
Crank position sensor
Other

Gus
Hello! I have the exact same issue on my 2008 rav4 150,000 mi 4cyl. Purrs in morning but after running an errand cranks fast but just spins—until10-15 min cool down then starts immediately and purrs. Replaced o2, camshaft sensors and bit throttle body/mass air unit. Fuel injector cleaner by amsoil fixes it for about 3 days only. Very random? Baffling as hell.
 

·
Registered
Joined
·
15 Posts
This is happening to us as well. We have a 2008 RAV4 that works fine first thing in the morning and after its been sitting all day while I'm at work. But if I stop to run an errand on the way home, when I get back in, it won't start. So, its like its only an issue when its hot. When I turn the key, it sounds like its starting but when I let go of the key, it just dies. When I turn the key again to start it, it just makes a grinding noise. At that point, I'm able to start it immediately by having someone jump me. Also, if I wait a bit, I'm able to start it just fine as well, as if its cooled off.
Exactly the same with mine. Cool down 10-15 min and starts instantly and purrs. Till I stop and turn off engine again. Maddening isnt it?
 

·
Registered
Joined
·
15 Posts
Hello! I have the exact same issue on my 2008 rav4 150,000 mi 4cyl. Purrs in morning but after running an errand cranks fast but just spins—until10-15 min cool down then starts immediately and purrs. Replaced o2, camshaft sensors and bit throttle body/mass air unit. Fuel injector cleaner by amsoil fixes it for about 3 days only. Very random? Baffling as hell.
Oh, and never a code...
 
1 - 20 of 38 Posts
Top