Toyota RAV4 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My pop has a 1999 with 206K miles that is driving fine below 50, but starts stumbling above 55. He reports it is getting worse, so I'm going to have to make a trip across town (1 hour drive) to diagnose and repair.

To me it sounds like a failing fuel pump, but are there any other ideas I can look at while there? I'd hate to have to make multiple trips.

Thanks!
 

·
Registered
Joined
·
9,061 Posts
Welcome! Have the spark plugs been changed in accordance with the Toyota owner's manual service schedule?
 

·
Registered
Joined
·
13 Posts
Try resetting your computer shows on tachometer

While stopped reset computer showing on tachometer using your foot increase engine speed 100 km/h=62 mph should be at 3000 rpm's so try 3500 take it up and release try 3800 up and release if it won't take 3800 back to 3500 then 3700 then back to 3500 do not hold your foot on throttle take it up let go and increase to 3000. Keep working at it over time till you get close to but not over red line remain under red line at all times. I f vehicle is driven in local speed 50 km/h=30 mph you will have to rest it again. That like you in your 80's running 10 miles or walking a block which makes more sense. Take time before long if on a hill or passing a vehicle its impossible to keep it at 100 km/h=62 mph unless you have cruise on you could be going 120 km/h=75 mph. Best of luck and remember its not a new vehicle and its only 4 cylinders not a V 8 or V 12 that just sails. John189:wink
 

·
Registered
Joined
·
11 Posts
Welcome! Have the spark plugs been changed in accordance with the Toyota owner's manual service schedule?
Wires too, may as well do the valve cover gasket and re-apply gasket to the tubes. Fixed my sluggish problem.
 
1 - 5 of 5 Posts
Top