Toyota RAV4 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Got these codes after replaced some 02 sensors, and reflashed the ecu(transmission problems).
After deleting codes with obd2 tool they always comes back after about 120 miles.
I finally came over this
video on youtube describing how to add capacitors and resistors to the downstream o2 sensor to smoothen out the signals, and after I added these components I definately have driven a much longer distance than before, and still no cel has lighten up. Crossing my fingers that it will continue this way.:smile
Any other tried this?
 

·
Registered
Joined
·
272 Posts
he does a nice job of explaining how to do the mod but doesn't explain why

I was hoping someone with more knowledge would respond

he isn't fixing the problem, he is just fooling the system into not throwing a code
the O2 sensors do more than just determine if the catalytic is doing its job or not, so I wonder if this mod also affects the ability of detecting other problems or can cause a problem

to me its no big deal, I just stop at the auto parts store whenever I have the time, every month or two (often I'm going to be there anyway) and read the code and turn off the light
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
he does a nice job of explaining how to do the mod but doesn't explain why
He does explain that this fix smoothen out the signals to the ecu. And as you may know, Toyota offered an upgrade of the ecu software in some of these cases. The ecu was to sensitive for the signals that came from the O2 sensors.
So I think this fix does about the same that upgrading the ecu soft, just much cheaper. Im so happy that I dont replaced the catalysator, the O2 sensors and finally reflashed the ecu, just to find out later that this free fix was just as good. :-D
 

·
Registered
Joined
·
7 Posts
i had that same problem for about a year. then i replaced my mass air flow sensor. this was the last thing i could think of to replace after replacing all my O2 sensors. but replacing the mass air flow sensor has fixed the issue completely.
 

·
Registered
1998 Rav4, manual transmission, 2WD, JDM engine installed in 2013
Joined
·
966 Posts
Mach III, I hope you are still around. Has your Rav4 had anymore P0420 codes? A few weeks ago I built and spliced a similar RC filter into the rear oxygen sensor wiring under the front right seat of my 1998 Rav4. So far, so good. Here's my DIY site for building this: Rear Oxygen Sensor Modification (for Code p0420) - ellessite
 
1 - 5 of 5 Posts
Top