Toyota RAV4 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi All,

I had this funny vibration while driving between 40 - 80 Km/h, so I took my car to the dealer. First they told me the problem is likely the transmission, then later said, no it is the torque converter.

So this was changed for me, however the car is vibrating at all speed now, a different kind of vibration that is almost causing me concussions. It feels and drives worse than before i took it in.

I plan to take it right back, Does anyone have an idea what is going on?
The car has only 42 K kilometres NOT miles.
 

·
Registered
Joined
·
30 Posts
If it's vibrating as bad as you say maybe something never got tightened up properly. Better only drive it back to the shop before more damage is done.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Thanks,
This is so annoying. One would think that when you get it back to the dealer, everything will be done right, but it looks like it is also a gamble to them.
 

·
Registered
Joined
·
1,577 Posts
I'd have it flatbedded to the dealer to be on the safe side. You know, CYA so they can't say you contributed to the problem by driving it. And protecting you from anything failing while driving it.

Good luck.
 

·
Registered
Joined
·
36 Posts
Thanks,
This is so annoying. One would think that when you get it back to the dealer, everything will be done right, but it looks like it is also a gamble to them.


I avoid the dealers at all costs unless the vehicle has problems covered under warranty. I do all my oil changes, transfer case, rear diff, except transmission which is far better by having it flushed for the V6, 4wd transmissions. Keep your receipts for maintenance to avoid warranty issues.
Dealer does not mean the best for your vehicle. They are all independently own and wipe their asses as they independently feel like.
 

·
Registered
Joined
·
3 Posts
I may be have the same problem with my 2015

My Rav4 2015 start to make noise vibration at about 2500 km the first 15 minutes after cold start.

At about 3000 km a motor oil or prestone leak appear over the joint transmission/motor and under around the drain on the same joint.

Now at 5000 km he do this all time (more when is cold) at 1850 rpm in 1st to 6 speed and I can ear so on neutral at 1850 rpm.

He stay 1 week at the dealer for repair and he come back with the same problems and one more...the dealer aligned my Rav4 I don't know why?
When I go straight the steering is turn at right (right is lower 1'' than the
left side....

I gone to another garage for align and He appear straight and after 20 km
he is back turn at right (steering)

I saw another dealer and he said it's impossible a Rav4 with a leak.

WOW!!!! TOYOTA!!!! Would you like buy my Rav4....He his for sale!
 
1 - 7 of 7 Posts
Top