Toyota RAV4 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter #1
Well, I figured 8 years was long enough so I finally changed out the coolant that came with the car.

It seems that I may have changed it too soon. It was clear with absolutely no particles of anything in it. Gone are the days of nasty gundge coming out of the radiator pipes.

I replaced it with a 50/50 mix of the stock stuff and a bottle of Redline Water Wetter.
 

·
Registered
Joined
·
779 Posts
Er, you should have looked at the coolant in mine when I bought it four months ago. Complete brown sludge. Flushed and it's still not as clear as I would like it.
 

·
Registered
Joined
·
273 Posts
Discussion Starter #3
I wonder if someone tried to use that radiator seal on it. It works sometimes but it is nasty.
 

·
Registered
Joined
·
779 Posts
No, I do not think so. That stuff is only a temporary fix and the last car I tried it on (which had a leak) the rad blew on a 70 mile drive (the bits clog up the fins and the pressure in the rad can build up). I have driven my Rav on some fairly hot and long drives since I have bought it. Any Rad seal put in by the previous owner would not have survived, if it was used to clog a leak. I think the brown was just a combination of mixed anti-freezes, rust and muck.
 

·
Registered
Joined
·
273 Posts
Discussion Starter #5
The sealer worked well in a blazer I had in high school. I did a complete flush about two months after putting it in. Lots of gunk. Worked well after that.

I sold the car about a year or so later, but who knows.
 
1 - 5 of 5 Posts
Top