Toyota RAV4 Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Vapor
Hey Rav4world. I own a 2006 Rav4 Base model with 90K miles on it and I've replaced the charcoal/vapor canister once already. (I bought a used one and it worked great...till today) I still have my old out and I had a mechanic check it out when they took it off and they couldn't figure out what was wrong with it. There didn't seem to be any issue with it but since the code was pointing to it being the 'main' issue. I bought a new one. I do not and refuse to replace the canister again. They're expensive and Toyota wants to charge me 15 hundred to replace 'Everything that has to do with the canister because my car has been submerged in water' Nope, that isn't the case at all. Its never been submerged in water and I've gone through puddles but nothing that deep. Anywho, tonight I messed with my gas cap and I might buy a new one if that's gonna fix it...I haven't checked to see if it was my gas cap though because I though I'd let it rest over night and see what that can do or if it does anything.
I'm looking for any type of advice that can point me in a better direction. Its only been 4 months with the new canister on the car and once it was put on I didn't see the lights anymore but today I got the same codes as I did last time. (The paper is in my car...ugh its cold outside...) Whichever codes people get with the canister. It didn't detect anything different just canister and pump stuff. I can post codes later on or tomorrow if they are necessary. I just don't know what to do about it, last time it happened it has rained a lot, the rain stopped and it dried up and the lights went off but I don't know that I can wait that long because I live in a area were it snows a lot and there's so much mud...
Someone point me in the right direction though, anyone else have the SAME problem as me??

Second problem: So my heater works amazing to find out that on my passenger side door, the one nearest to do the door is chilly and isn't super warm like the one on the drive side door. If you get towards the middle, I start to lose a little bit of heat, not to much but enough to tell and I'm not sure what to do, what to look for, ect. Any ideas on this problem too? Solutions to any of my Toyota Problems ;(
 

·
Registered
Joined
·
659 Posts
The fix depends which trouble codes you have. There is many things involved in the whole EVAP system... not only the canister. There is a TSB about water infiltration in the canister and vent filter from 2006 to 2011 models. The TSB apply only if all five DTCs are present: P043E, P043F, P2401, P2402 and P2419. There is many pieces to change, and a fuel tank protector to add.
 
1 - 2 of 2 Posts
Top