Toyota RAV4 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
So - my wife is driving and the ABS & Brake lights illuminate; she tries to engage cruise and only gets a flashing light. Tells me this happened one other time - an intermittent problem. I put a scan tool on it and get the above codes - with the P1578 code appearing twice. Research shows that the U0073 is 'ECM Mod Bus Off' and the P1578 is either a 'brake booster vacuum sensor' or 'yaw rate sensor' malfunction. The cruise is throwing me for a loop, but I'm guessing it won't engage if there's some sort of detected problem in the VSC system.

My limited research seems to point to maybe three things:

1. Defective brake light switch
2. Defective VSC computer
3. Defective sensor (yaw rate, ABS or someother - take your pick) or connection

Looking for suggestions, since a VSC computer might easily be the most expensive issue and the brake light switch the least expensive. Tracking down a loose connection under that hood or under the car might be the nightmare.
 

·
Super Moderator
Joined
·
10,126 Posts
Is the RAV4 set up for towing?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
No, it is not.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Wondering about this: Could it be an intermittment failure of the ABS module? I know there are a lot of folks who get codes from bad electrical connections...I'll probalby take off each wheel and check the ABS harness & sensor...I'm pretty sure the P1578 code was not a brake booster but more of an ABS fault...low voltage somewhere...
 
1 - 4 of 4 Posts
Top