Toyota RAV4 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello RAV4 folks. I've had mine since 2010 with 88k miles and going strong. I have a question for the group. I know a lot of people have put aftermarket navigation into their vehicles and I am about to do the same. When I remove the radio, there is an unused harness taped to the bundle of wires which was connected to nothing.
Any idea what this harness could be?

Best
 

·
Registered
Joined
·
137 Posts
Pictures, year, JBL or not.
mine was a base 2007 had 3 connectors the main big one, a little one with the aux port and the antenna.
the little one threw me for the longest time.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
it's a grey harness with a purple and white wire. I wonder if it is a VSS wire and the harness is for OEM navigation.
 

·
Registered
Joined
·
137 Posts
crutchfield.com is your friend.
You still arent telling me what year you have, whether you have steering wheel buttons, JBL amplifier. ..

Metra makes a basic cable 70-1761 Metra Part # 70-1761 | Toyota wire harness | Metra Online
which will give you the main harness and the little harness

Metra also makes an optional supplemental harness that connects to the steering wheel controls and allows you to re-use the old 3.5mm AUX in jack
70-8114 Metra Online

If you have the JBL sub amplifier, you have a whole different set of adaptors.. I suggest you visit crutchfield.com and look at the installation parts they provide for your specific make/model/options you can take the parts list to amazon or your local stereo shop if you want.

Again, I simply dont know the answer to your question. I wonder what it is too.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Sorry to have been so vague. 2010 Limited with JBL. I've already installed the adaptor for the JBL amplification. I do have steering wheel buttons, but this harness was unused for the factory radio as well.
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,716 Posts
Yeah, that extra connector was probably for the NAV unit. The purple wire is definitely the VSS (vehicle speed signal).
 
1 - 6 of 6 Posts
Top