Toyota RAV4 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Anyone know of the vehicle speed sensor location? Lots of info on older gens but nothing for 2011. I know about where it should be but can not find it.
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,716 Posts
Anyone know of the vehicle speed sensor location? Lots of info on older gens but nothing for 2011. I know about where it should be but can not find it.
It would help if we knew what engine and transmission you have. You have put nothing on your profile page.
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,716 Posts
It's a 2wd 4 cylinder (base model).
According to my information, there are 2 VSS on the transaxle, both part number 89413-24010. I found a picture of the u241e on Google. The red arrows point to the 2 sensors, and the blue arrow points to where the starter is mounted. You may need to remove the battery and tray to get to them.

 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
Wow, I had the battery out and was going for the tray until I saw the 6 bolts I had to remove. figure I'd first jack it up and see if its under the trans. Good find! Saves me some work.
 

·
Your Humble Administrator
2008 RAV4 Limited V6
Joined
·
16,716 Posts
As I recall, you applied 12 volts directly to the purple VSS wire on the radio plug? That wire goes directly to the instrument cluster (combination meter), not the speed sensor itself. Have you downloaded the electrical wiring diagrams from my profile page?
 

·
Registered
Joined
·
42 Posts
Discussion Starter #7
did you just reply to my post on here? in this thread instead? That was a bit confusing.

Your assumption is correct. I grabbed the wiring diagram for 2011, thx for that. There are 12 pdfs that were in the zip but nothing talking about about the ipc.

If the icp received damage I'd think (correct me if I'm wrong) that it would be a permanent or noticeable damage that does not go away when I clear the codes. The current issue is that I get a p0500 error as soon as I leave 1st gear. Both VSS's have been test and appear ok. The other thing I noticed was the auto LSD also comes on and blinks. My guess is, that is normal when the VSS is bad (or maybe visa versa). Though if that wire first goes to the icp then something must have been stressed in that area I agree.
 

·
Registered
Joined
·
10 Posts
wiring diagrams

As I recall, you applied 12 volts directly to the purple VSS wire on the radio plug? That wire goes directly to the instrument cluster (combination meter), not the speed sensor itself. Have you downloaded the electrical wiring diagrams from my profile page?
Hi JuneBug, I came across this post while researching a similar problem. Do you still have the wiring diagrams available for download? I need to replace the speed sensor wiring on my 2010 RAV4 Sport. Thanks...
 

·
Registered
Joined
·
2 Posts
Can you help me with more rav4 speed sensor information?

My 2011 Rav4 has P0500, and have almost the symptoms as ulao's car before:
Cannot move, grinding in shift, engine code P0500, no other code.
Will replacing speed sensors solve the problems?

Thank you very much!
 
1 - 9 of 9 Posts
Top