Toyota RAV4 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
I recently purchased a 2012 CPO RAV4 4-cyl 4WD. During the test drive, I did not notice the vibrations at higher speeds, but after driving it for a month, I think something is off.

At speeds over 60mph, I begin to notice a vibration on the passenger side in both seats. At 75mph, they begin to shake quite bad and this shaking is also present in the floorboards as well as in the base of the drivers seat. I have already had the tires rotated and balanced (although I'm not sure if they were road force balanced) and have an appointment to have the dealership look at this next week. Any advice on what it could be?

EDIT: the rotation and balance did not affect the location or intensity of the vibration. I also occasionally will feel it in the steering wheel/pedals. The roads should not be to blame as it happens on relatively new asphalt I have driven on with other vehicles and never experienced these issues.
 

·
Registered
Joined
·
137 Posts
mine was doing that when i first got it.. 2007 4cyl AWD.. turned out it was the front struts.. and motor mounts.
CPO might give you some leverage to fix yours. My Autonation Honda dealer in Mesa chumped me on mine.
But its all good now.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
mine was doing that when i first got it.. 2007 4cyl AWD.. turned out it was the front struts.. and motor mounts.
CPO might give you some leverage to fix yours. My Autonation Honda dealer in Mesa chumped me on mine.
But its all good now.
how much did it cost to fix it if CPO refuses to cover it?
 
1 - 5 of 5 Posts
Top